summaryrefslogtreecommitdiff
path: root/docbook/CMakeLists.txt
diff options
context:
space:
mode:
authorHadriel Kaplan <hadrielk@yahoo.com>2014-02-02 22:49:30 -0500
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2014-02-14 10:11:50 +0000
commitc4f1777a97415b8b7d76eda27dcd6f238501e5f3 (patch)
treecbbd054deb3b70052b9cf95e655378b941005e43 /docbook/CMakeLists.txt
parent7a503703ac0c4ce5bc00225d6cd61d83c1ff947e (diff)
downloadwireshark-c4f1777a97415b8b7d76eda27dcd6f238501e5f3.tar.gz
Adds support for Lua struct library so one can pack/unpack binary structures
This is based on Roberto Ierusalimschy's struct library, along with additional options based on Flemming Madsen's patch to the lua-users mailing list, and some changes I made to support 64-bit integer packing/unpacking. Details are in the top comments for wslua_struct.c. This also includes a test script. Change-Id: Ifcd0116ba013d5c760927721c8d6e9f28965534b Reviewed-on: https://code.wireshark.org/review/98 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'docbook/CMakeLists.txt')
-rw-r--r--docbook/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/docbook/CMakeLists.txt b/docbook/CMakeLists.txt
index 7e4d814ca7..bbcf284b2d 100644
--- a/docbook/CMakeLists.txt
+++ b/docbook/CMakeLists.txt
@@ -310,6 +310,8 @@ set(WSLUA_MODULES
${CMAKE_SOURCE_DIR}/epan/wslua/wslua_tree.c
${CMAKE_SOURCE_DIR}/epan/wslua/wslua_tvb.c
${CMAKE_SOURCE_DIR}/epan/wslua/wslua_util.c
+ ${CMAKE_SOURCE_DIR}/epan/wslua/wslua_int64.c
+ ${CMAKE_SOURCE_DIR}/epan/wslua/wslua_struct.c
)
ADD_CUSTOM_COMMAND(