summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2006-05-31 00:23:01 +0000
committerGerald Combs <gerald@wireshark.org>2006-05-31 00:23:01 +0000
commitb15974d094e96ced61fefeff35be96add2b6e7a4 (patch)
tree476bdd5efe70987b1f7252072e7a1b6a0adf849f /epan/Makefile.am
parent6deb90af7b1eee58fe564ebeaee57066bca508e2 (diff)
downloadwireshark-b15974d094e96ced61fefeff35be96add2b6e7a4.tar.gz
libethereal -> libwireshark. idl2eth -> idl2wrs. There are a _lot_ of
changes here. It compiles OK on OS X, but hasn't been tested anywhere else. svn path=/trunk/; revision=18260
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am22
1 files changed, 11 insertions, 11 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index f5155a2b27..2ae673e9e2 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -29,18 +29,18 @@ SUBDIRS = ftypes dfilter dissectors
ACLOCAL_AMFLAGS = `../aclocal-flags`
-lib_LTLIBRARIES = libethereal.la
-libethereal_la_LDFLAGS = -version-info 0:1:0
+lib_LTLIBRARIES = libwireshark.la
+libwireshark_la_LDFLAGS = -version-info 0:1:0
include Makefile.common
INCLUDES = -I$(srcdir)/.. -I$(srcdir)/$(LEMON)
-libethereal_la_SOURCES = \
- $(LIBETHEREAL_SRC) \
- $(LIBETHEREAL_INCLUDES)
+libwireshark_la_SOURCES = \
+ $(LIBWIRESHARK_SRC) \
+ $(LIBWIRESHARK_INCLUDES)
-EXTRA_libethereal_la_SOURCES = \
+EXTRA_libwireshark_la_SOURCES = \
g_ascii_strtoull.c \
g_ascii_strtoull.h \
inet_aton.c \
@@ -54,7 +54,7 @@ EXTRA_DIST = \
dtd_parse.l \
dtd_preparse.l \
enterprise-numbers \
- libethereal.def \
+ libwireshark.def \
Makefile.common \
Makefile.nmake \
make-sminmpec.pl \
@@ -64,8 +64,8 @@ EXTRA_DIST = \
doxygen.cfg.in
CLEANFILES = \
- libethereal.a \
- libethereal.la \
+ libwireshark.a \
+ libwireshark.la \
*~
DISTCLEANFILES = \
@@ -84,8 +84,8 @@ MAINTAINERCLEANFILES = \
#
# Add the object files for missing routines, if any.
#
-libethereal_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la @ADNS_LIBS@ @LIBGNUTLS_LIBS@ @KRB5_LIBS@ @SNMP_LIBS@ @SSL_LIBS@ -lm
-libethereal_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
+libwireshark_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la @ADNS_LIBS@ @LIBGNUTLS_LIBS@ @KRB5_LIBS@ @SNMP_LIBS@ @SSL_LIBS@ -lm
+libwireshark_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ dfilter/libdfilter.la ftypes/libftypes.la dissectors/libdissectors.la
tvbtest: tvbtest.o tvbuff.o except.o strutil.o
$(LINK) $^ $(GLIB_LIBS) -lz