summaryrefslogtreecommitdiff
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-12-05 01:49:22 -0800
committerMichael Mann <mmann78@netscape.net>2015-12-05 12:08:52 +0000
commitb56f53884be3bab935058b2bbbb4da0b8bbbe7f6 (patch)
treea03a91e0be6188dad8ce6b436f68ac94207dd57f /epan/Makefile.am
parent4d337f421389e901bf1d4246f9ecb2f7b363aef0 (diff)
downloadwireshark-b56f53884be3bab935058b2bbbb4da0b8bbbe7f6.tar.gz
Build Flex-generated files with "warnings are errors".
We shouldn't be getting warnings at this point. Change-Id: I363a48546cb8d916425f42962ae1697d52ed9a29 Reviewed-on: https://code.wireshark.org/review/12436 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am26
1 files changed, 8 insertions, 18 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 2383af0433..befa2f21a4 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -39,7 +39,7 @@ DIST_SUBDIRS = $(SUBDIRS) $(wslua_dist_dir)
ACLOCAL_AMFLAGS = `../aclocal-flags`
-noinst_LTLIBRARIES = libwireshark_generated.la libwireshark_asmopt.la
+noinst_LTLIBRARIES = libwireshark_asmopt.la
lib_LTLIBRARIES = libwireshark.la
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
libwireshark_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
@@ -50,26 +50,19 @@ AM_CPPFLAGS = -I$(srcdir)/.. -I$(srcdir)/$(LEMON) -I$(builddir)/wslua \
@LUA_CFLAGS@ $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS) \
$(LIBSMI_CFLAGS) $(LIBGEOIP_CFLAGS) $(PY_CFLAGS)
-AM_NON_GENERATED_CFLAGS =-DWS_BUILD_DLL
+AM_CFLAGS =-DWS_BUILD_DLL
if HAVE_WARNINGS_AS_ERRORS
-AM_NON_GENERATED_CFLAGS += -Werror
+AM_CFLAGS += -Werror
endif
-#Since code generated by lex may trigger gcc warnings, we are now generating two
-#libraries. A single library is generated with the lex code without the barrier
-#"stop on warning". An other library is generated from the remaining source
-#files with the "stop on warning" barrier.
libwireshark_la_SOURCES = \
- $(LIBWIRESHARK_SRC) \
- $(LIBWIRESHARK_INCLUDES)
-libwireshark_la_CFLAGS = $(AM_NON_GENERATED_CFLAGS)
-
-libwireshark_generated_la_SOURCES = \
- $(LIBWIRESHARK_GENERATED_C_FILES) \
+ $(LIBWIRESHARK_SRC) \
+ $(LIBWIRESHARK_INCLUDES) \
+ $(LIBWIRESHARK_GENERATED_C_FILES) \
$(LIBWIRESHARK_GENERATED_HEADER_FILES)
-nodist_libwireshark_generated_la_SOURCES = \
+nodist_libwireshark_la_SOURCES = \
$(NODIST_LIBWIRESHARK_GENERATED_C_FILES) \
$(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES)
@@ -103,8 +96,6 @@ CLEANFILES = \
doxygen-epan.tag \
libwireshark.a \
libwireshark.la \
- libwireshark_generated.a \
- libwireshark_generated.la \
libwireshark_asmopt.a \
libwireshark_asmopt.la \
*~
@@ -123,7 +114,6 @@ MAINTAINERCLEANFILES = \
# Add the object files for missing routines, if any.
#
libwireshark_la_LIBADD = \
- libwireshark_generated.la \
libwireshark_asmopt.la crypt/libairpdcap.la \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la dissectors/libfiledissectors.la \
@@ -135,7 +125,7 @@ libwireshark_la_LIBADD = \
${top_builddir}/wsutil/libwsutil.la -lm
libwireshark_la_DEPENDENCIES = \
- libwireshark_generated.la compress/liblzxpress.la\
+ compress/liblzxpress.la\
libwireshark_asmopt.la crypt/libairpdcap.la \
ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
dissectors/libdirtydissectors.la nghttp2/libnghttp2.la \