summaryrefslogtreecommitdiff
path: root/epan/compress/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Patou <mat@matws.net>2014-10-10 16:53:20 -0400
committerMichael Mann <mmann78@netscape.net>2014-10-30 15:28:47 +0000
commitcda985d3eb637454fb773157893d4d8cb18313a2 (patch)
tree04a5c56720817e7a40ad5984fdbdd89da8525827 /epan/compress/Makefile.am
parentfea733e82b290882b592adfef4b8ae621245f5cd (diff)
downloadwireshark-cda985d3eb637454fb773157893d4d8cb18313a2.tar.gz
Create the compress module for compression functions.
For the moment there is only the lzxpress compression used by DRS Bug: 10546 Change-Id: Ifc7e1767934224c0198f0b09caa3efbad979ca1f Reviewed-on: https://code.wireshark.org/review/4600 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'epan/compress/Makefile.am')
-rw-r--r--epan/compress/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/epan/compress/Makefile.am b/epan/compress/Makefile.am
new file mode 100644
index 0000000000..9f86830c5e
--- /dev/null
+++ b/epan/compress/Makefile.am
@@ -0,0 +1,55 @@
+# Makefile.am
+# Automake file for the compress for Wireshark
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include Makefile.common
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)
+
+noinst_LTLIBRARIES = liblzxpress.la
+
+CLEANFILES = \
+ liblzxpress.a \
+ liblzxpress.la \
+ *~
+
+DISTCLEANFILES =
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+
+liblzxpress_la_SOURCES = \
+ $(LIBLZXPRESS_SRC) \
+ $(LIBLZXPRESS_INCLUDES)
+
+EXTRA_DIST = \
+ Makefile.common \
+ Makefile.nmake
+
+checkapi:
+ $(PERL) ../../tools/checkAPIs.pl -g termoutput -build \
+ $(LIBLZXPRESS_SRC)