summaryrefslogtreecommitdiff
path: root/epan/crypt/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /epan/crypt/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
downloadwireshark-a16d401b25c85ffb7fde6c46b51cb7048112f885.tar.gz
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/crypt/Makefile.am')
-rw-r--r--epan/crypt/Makefile.am37
1 files changed, 25 insertions, 12 deletions
diff --git a/epan/crypt/Makefile.am b/epan/crypt/Makefile.am
index 60a8a2b291..b7f2a36556 100644
--- a/epan/crypt/Makefile.am
+++ b/epan/crypt/Makefile.am
@@ -19,13 +19,36 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
noinst_LTLIBRARIES = libairpdcap.la
+include Custom.common
+
+libairpdcap_la_SOURCES = \
+ airpdcap.c \
+ airpdcap_ccmp.c \
+ airpdcap_debug.c \
+ airpdcap_rijndael.c \
+ airpdcap_tkip.c \
+ airpdcap_debug.h \
+ airpdcap_interop.h \
+ airpdcap_int.h \
+ airpdcap_rijndael.h \
+ airpdcap_system.h \
+ airpdcap_user.h \
+ airpdcap_ws.h \
+ kasumi.h \
+ wep-wpadefs.h \
+ $(CUSTOM_CRYPTO_SRC)
+
+EXTRA_DIST = \
+ Custom.common \
+ CMakeLists.txt \
+ CMakeListsCustom.txt.example
+
CLEANFILES = \
libairpdcap.a \
libairpdcap.la \
@@ -36,17 +59,7 @@ DISTCLEANFILES =
MAINTAINERCLEANFILES = \
Makefile.in
-libairpdcap_la_SOURCES = \
- $(LIBAIRPDCAP_SRC) \
- $(LIBAIRPDCAP_INCLUDES)
-
-EXTRA_DIST = \
- Custom.common \
- Makefile.common \
- CMakeLists.txt \
- CMakeListsCustom.txt.example
-
checkapi:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \
-sourcedir=$(srcdir) \
- $(LIBAIRPDCAP_SRC)
+ $(libairpdcap_la_SOURCES)