summaryrefslogtreecommitdiff
path: root/epan/dfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2016-03-11 19:51:39 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2016-05-02 12:01:24 +0000
commit2e23b506c766d98966ed213c760b2aa6232ba1fe (patch)
treee15eec1049e10419d869dea459730791ec2bc128 /epan/dfilter/CMakeLists.txt
parent231f6b5035e4f001eca22029b58cf4c498d624bd (diff)
downloadwireshark-2e23b506c766d98966ed213c760b2aa6232ba1fe.tar.gz
Add checkAPI calls to CMake.
This generates a top level target, checkAPI, that is excluded from the ALL build target, so must be run separately. On Windows using a Visual Studio generator, call msbuild /p:Configuration=RelWithDebInfo checkAPI.vcxproj Change-Id: I44a57c564dcfc75499463b942436f4b920a82478 Reviewed-on: https://code.wireshark.org/review/14873 Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'epan/dfilter/CMakeLists.txt')
-rw-r--r--epan/dfilter/CMakeLists.txt17
1 files changed, 15 insertions, 2 deletions
diff --git a/epan/dfilter/CMakeLists.txt b/epan/dfilter/CMakeLists.txt
index 0b59c34f7b..102724921b 100644
--- a/epan/dfilter/CMakeLists.txt
+++ b/epan/dfilter/CMakeLists.txt
@@ -51,16 +51,17 @@ if(WERROR_COMMON_FLAGS)
)
endif()
-add_lex_files(DFILTER_FILES
+add_lex_files(LEX_FILES GENERATED_FILES
scanner.l
)
-add_lemon_files(DFILTER_FILES
+add_lemon_files(LEMON_FILES GENERATED_FILES
grammar.lemon
)
add_library(dfilter OBJECT
${DFILTER_FILES}
+ ${GENERATED_FILES}
)
set_target_properties(dfilter PROPERTIES
@@ -68,6 +69,18 @@ set_target_properties(dfilter PROPERTIES
COMPILE_DEFINITIONS "WS_BUILD_DLL"
)
+CHECKAPI(
+ NAME
+ dfilter
+ SWITCHES
+ -g termoutput -build
+ SOURCES
+ ${DFILTER_FILES}
+# LEX files commented out due to use of malloc, free etc.
+# ${LEX_FILES}
+ ${LEMON_FILES}
+)
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#