summaryrefslogtreecommitdiff
path: root/epan/dfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-09 19:13:01 +0000
committerKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-09 19:13:01 +0000
commit7ca2babc1e307c727f5f8a4e7052f6b630894af0 (patch)
tree7a6669e5ab5fbd6578e5daf0d99cbc0d01c3ed5d /epan/dfilter/CMakeLists.txt
parente4d4f81768e45cd7b3c86009d2e0360e2fc4e08c (diff)
downloadwireshark-7ca2babc1e307c727f5f8a4e7052f6b630894af0.tar.gz
Add epan/dfilter/CMakeLists.txt which creates a static dfilter library
svn path=/trunk/; revision=30441
Diffstat (limited to 'epan/dfilter/CMakeLists.txt')
-rw-r--r--epan/dfilter/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/epan/dfilter/CMakeLists.txt b/epan/dfilter/CMakeLists.txt
new file mode 100644
index 0000000000..eeee4582e9
--- /dev/null
+++ b/epan/dfilter/CMakeLists.txt
@@ -0,0 +1,53 @@
+# CMakeLists.txt
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+set(DFILTER_FILES
+ dfilter.c
+ dfilter-macro.c
+ dfunctions.c
+ dfvm.c
+ drange.c
+ gencode.c
+ semcheck.c
+ sttype-function.c
+ sttype-integer.c
+ sttype-pointer.c
+ sttype-range.c
+ sttype-string.c
+ sttype-test.c
+ syntax-tree.c
+)
+
+add_lex_files(DFILTER_FILES
+ scanner.l
+)
+
+add_lemon_files(DFILTER_FILES
+ grammar.lemon
+)
+
+add_library(dfilter STATIC
+ ${DFILTER_FILES}
+)