summaryrefslogtreecommitdiff
path: root/epan/dfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-10-11 07:28:26 +0000
committerJörg Mayer <jmayer@loplof.de>2009-10-11 07:28:26 +0000
commitec7380a6b1684d35c5d8da83f1f38c1b6d6dceb5 (patch)
tree770fff01ec894e5d6e6164d8cee5fc86069a1d17 /epan/dfilter/CMakeLists.txt
parent5ea31fa45014e0475b4816c9b3999ca0d11dcd14 (diff)
downloadwireshark-ec7380a6b1684d35c5d8da83f1f38c1b6d6dceb5.tar.gz
Creatig static sublibs was not a good idea:
========================================================================= "du -s build" with sublibs: 396868 build ----------------------------------- "du -s build" without sublibs: 197588 build/ ========================================================================= tshark with sublibs: -rwxr-xr-x 1 jmayer users 27399706 2009-10-11 08:39 tshark* ----------------------------------- tshark without sublibs: -rwxr-xr-x 1 jmayer users 226748 2009-10-11 09:05 tshark* ========================================================================= So undo the following patches: ------------------------------------------------------------------------ r30459 | krj | 2009-10-10 07:08:48 +0200 (Sa, 10 Okt 2009) | 1 line Sort subdirectories alphabetically ------------------------------------------------------------------------ r30458 | krj | 2009-10-10 07:03:36 +0200 (Sa, 10 Okt 2009) | 1 line Add epan/dissectors/CMakeLists.txt which creates a static dissectors library ------------------------------------------------------------------------ --> readd!! *** r30443 | krj | 2009-10-09 21:43:42 +0200 (Fr, 09 Okt 2009) | 1 line Rename DISSECTOR_ASM_UTILS to LIBWIRESHARK_ASM_FILES since these files belongs to ep an not dissectors ------------------------------------------------------------------------ r30442 | krj | 2009-10-09 21:17:26 +0200 (Fr, 09 Okt 2009) | 1 line Add epan/ftypes/CMakeLists.txt which creates a static ftypes library ------------------------------------------------------------------------ r30441 | krj | 2009-10-09 21:13:01 +0200 (Fr, 09 Okt 2009) | 1 line Add epan/dfilter/CMakeLists.txt which creates a static dfilter library ------------------------------------------------------------------------ r30440 | krj | 2009-10-09 21:05:29 +0200 (Fr, 09 Okt 2009) | 1 line Add epan/crypt/CMakeLists.txt which creates a static crypt library ------------------------------------------------------------------------ r30439 | krj | 2009-10-09 20:22:22 +0200 (Fr, 09 Okt 2009) | 1 line Add epan/crc/CMakeLists.txt which creates a static crc library ------------------------------------------------------------------------ To avoid merge problems, I needed to revert r30443 as well, will readd this one in my next patch. svn path=/trunk/; revision=30494
Diffstat (limited to 'epan/dfilter/CMakeLists.txt')
-rw-r--r--epan/dfilter/CMakeLists.txt53
1 files changed, 0 insertions, 53 deletions
diff --git a/epan/dfilter/CMakeLists.txt b/epan/dfilter/CMakeLists.txt
deleted file mode 100644
index eeee4582e9..0000000000
--- a/epan/dfilter/CMakeLists.txt
+++ /dev/null
@@ -1,53 +0,0 @@
-# CMakeLists.txt
-#
-# $Id$
-#
-# Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@wireshark.org>
-# Copyright 1998 Gerald Combs
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-#
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-
-set(DFILTER_FILES
- dfilter.c
- dfilter-macro.c
- dfunctions.c
- dfvm.c
- drange.c
- gencode.c
- semcheck.c
- sttype-function.c
- sttype-integer.c
- sttype-pointer.c
- sttype-range.c
- sttype-string.c
- sttype-test.c
- syntax-tree.c
-)
-
-add_lex_files(DFILTER_FILES
- scanner.l
-)
-
-add_lemon_files(DFILTER_FILES
- grammar.lemon
-)
-
-add_library(dfilter STATIC
- ${DFILTER_FILES}
-)