summaryrefslogtreecommitdiff
path: root/epan/nghttp2/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /epan/nghttp2/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
downloadwireshark-a16d401b25c85ffb7fde6c46b51cb7048112f885.tar.gz
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'epan/nghttp2/Makefile.am')
-rw-r--r--epan/nghttp2/Makefile.am34
1 files changed, 23 insertions, 11 deletions
diff --git a/epan/nghttp2/Makefile.am b/epan/nghttp2/Makefile.am
index 0845718d99..d5b8323b0d 100644
--- a/epan/nghttp2/Makefile.am
+++ b/epan/nghttp2/Makefile.am
@@ -19,7 +19,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(LIBNGHTTP2_CFLAGS) \
@@ -27,6 +26,29 @@ AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(LIBNGHTTP2_CFLAGS) \
noinst_LTLIBRARIES = libnghttp2.la
+libnghttp2_la_SOURCES = \
+ nghttp2_buf.c \
+ nghttp2_hd.c \
+ nghttp2_hd_huffman.c \
+ nghttp2_hd_huffman_data.c \
+ nghttp2_helper.c \
+ nghttp2_mem.c \
+ nghttp2_rcbuf.c \
+ nghttp2_buf.h \
+ nghttp2_hd.h \
+ nghttp2_hd_huffman.h \
+ nghttp2_helper.h \
+ nghttp2_int.h \
+ nghttp2_mem.h \
+ nghttp2_rcbuf.h \
+ nghttp2.h \
+ nghttp2ver.h
+
+EXTRA_DIST = \
+ .editorconfig \
+ README.nghttp2 \
+ CMakeLists.txt
+
CLEANFILES = \
libnghttp2.a \
libnghttp2.la \
@@ -37,16 +59,6 @@ DISTCLEANFILES =
MAINTAINERCLEANFILES = \
Makefile.in
-libnghttp2_la_SOURCES = \
- $(LIBNGHTTP2_SRC) \
- $(LIBNGHTTP2_INCLUDES)
-
-EXTRA_DIST = \
- .editorconfig \
- Makefile.common \
- README.nghttp2 \
- CMakeLists.txt
-
#
# Editor modelines - https://www.wireshark.org/tools/modelines.html
#