summaryrefslogtreecommitdiff
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorHadriel Kaplan <hadrielk@yahoo.com>2014-02-02 22:49:30 -0500
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2014-02-14 10:11:50 +0000
commitc4f1777a97415b8b7d76eda27dcd6f238501e5f3 (patch)
treecbbd054deb3b70052b9cf95e655378b941005e43 /epan/wslua/Makefile.am
parent7a503703ac0c4ce5bc00225d6cd61d83c1ff947e (diff)
downloadwireshark-c4f1777a97415b8b7d76eda27dcd6f238501e5f3.tar.gz
Adds support for Lua struct library so one can pack/unpack binary structures
This is based on Roberto Ierusalimschy's struct library, along with additional options based on Flemming Madsen's patch to the lua-users mailing list, and some changes I made to support 64-bit integer packing/unpacking. Details are in the top comments for wslua_struct.c. This also includes a test script. Change-Id: Ifcd0116ba013d5c760927721c8d6e9f28965534b Reviewed-on: https://code.wireshark.org/review/98 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index e5789c1d7d..241a2a63ad 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -40,6 +40,7 @@ wslua_modules = \
$(srcdir)/wslua_gui.c \
$(srcdir)/wslua_util.c \
$(srcdir)/wslua_field.c \
+ $(srcdir)/wslua_struct.c \
$(srcdir)/wslua_dumper.c
libwslua_la_SOURCES = \
@@ -129,7 +130,8 @@ checkapi:
wslua_int64.c \
wslua_pinfo.c \
wslua_proto.c \
- wslua_listener.c \
+ wslua_struct.c \
+ wslua_tree.c \
wslua_tree.c \
wslua_tvb.c \
wslua_util.c