summaryrefslogtreecommitdiff
path: root/epan/wslua/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2007-08-02 16:06:13 +0000
committerGuy Harris <guy@alum.mit.edu>2007-08-02 16:06:13 +0000
commitdd8633204600dafbc51c298534cda6f6d76ed3d3 (patch)
tree60dd2fa99996657186f4ab4ae23889eb779c294d /epan/wslua/Makefile.am
parentad76a231d4880c766c8236774ed8115afee5ba5e (diff)
downloadwireshark-dd8633204600dafbc51c298534cda6f6d76ed3d3.tar.gz
Gak. <> makes it too easy to make these make- scripts do what the rest
do, and take $(srcdir) as the first argument. Back the previous changes out, for now. svn path=/trunk/; revision=22441
Diffstat (limited to 'epan/wslua/Makefile.am')
-rw-r--r--epan/wslua/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/epan/wslua/Makefile.am b/epan/wslua/Makefile.am
index 9454aaf06a..8784ffa09c 100644
--- a/epan/wslua/Makefile.am
+++ b/epan/wslua/Makefile.am
@@ -18,11 +18,9 @@
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#
-include Makefile.common
-
if HAVE_WARNINGS_AS_ERRORS
AM_CFLAGS = -Werror
endif
@@ -31,8 +29,19 @@ INCLUDES = -I$(top_srcdir) @LUA_INCLUDES@
noinst_LTLIBRARIES = libwslua.la
+wslua_modules = \
+ $(srcdir)/wslua_tvb.c \
+ $(srcdir)/wslua_proto.c \
+ $(srcdir)/wslua_tree.c \
+ $(srcdir)/wslua_pinfo.c \
+ $(srcdir)/wslua_listener.c \
+ $(srcdir)/wslua_gui.c \
+ $(srcdir)/wslua_util.c \
+ $(srcdir)/wslua_field.c \
+ $(srcdir)/wslua_dumper.c
+
libwslua_la_SOURCES = \
- $(MODULES) \
+ $(wslua_modules) \
taps_wslua.c \
register_wslua.c \
init_wslua.c \
@@ -72,7 +81,6 @@ EXTRA_DIST = \
template-init.lua \
make-init-lua.pl \
make-taps.pl \
- Makefile.common \
Makefile.nmake
taps_used = \