summaryrefslogtreecommitdiff
path: root/extcap/Makefile.am
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2016-02-10 15:45:45 +0100
committerRoland Knall <rknall@gmail.com>2016-09-16 08:07:30 +0000
commit47650d357e3115e89b854f195b385855c4703a21 (patch)
treecddd7aa4afabed55153e4729664f22fc9005f61f /extcap/Makefile.am
parent1cd3587b739c5e5aa1b5fd75c8df4ca374f4a6ff (diff)
downloadwireshark-47650d357e3115e89b854f195b385855c4703a21.tar.gz
extcap: add udpdump.
Udpdump is a generic UDP receiver that exports datagram in PCAP format. Change-Id: I52620a92b12530b6f9b5449c43e692663acdfc14 Reviewed-on: https://code.wireshark.org/review/17195 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Roland Knall <rknall@gmail.com>
Diffstat (limited to 'extcap/Makefile.am')
-rw-r--r--extcap/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/extcap/Makefile.am b/extcap/Makefile.am
index 7c3bdba14b..139179146a 100644
--- a/extcap/Makefile.am
+++ b/extcap/Makefile.am
@@ -33,9 +33,10 @@ extcap_PROGRAMS = \
@androiddump_bin@ \
@randpktdump_bin@ \
@sshdump_bin@ \
- @ciscodump_bin@
+ @ciscodump_bin@ \
+ @udpdump_bin@
-EXTRA_PROGRAMS = androiddump randpktdump sshdump ciscodump
+EXTRA_PROGRAMS = androiddump randpktdump sshdump ciscodump udpdump
androiddump_SOURCES = \
androiddump.c \
@@ -106,6 +107,23 @@ ciscodump_LDADD = \
@GLIB_LIBS@ \
@LIBSSH_LIBS@
+udpdump_SOURCES = \
+ udpdump.c \
+ extcap-base.c
+
+if ENABLE_STATIC
+ udpdump_LDFLAGS = -Wl,-static -all-static
+else
+ udpdump_LDFLAGS = -export-dynamic
+endif
+
+# Libraries and plugin flags with which to link udpdump.
+udpdump_LDADD = \
+ ../writecap/libwritecap.a \
+ ../wsutil/libwsutil.la \
+ ../epan/libwireshark.la \
+ @GLIB_LIBS@
+
noinst_HEADERS = \
extcap-base.h \
ssh-base.h