summaryrefslogtreecommitdiff
path: root/extcap/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /extcap/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
downloadwireshark-a16d401b25c85ffb7fde6c46b51cb7048112f885.tar.gz
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'extcap/Makefile.am')
-rw-r--r--extcap/Makefile.am30
1 files changed, 25 insertions, 5 deletions
diff --git a/extcap/Makefile.am b/extcap/Makefile.am
index 81bcd2b549..7c3bdba14b 100644
--- a/extcap/Makefile.am
+++ b/extcap/Makefile.am
@@ -19,7 +19,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include ../Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
@@ -28,17 +27,20 @@ MAINTAINERCLEANFILES = \
Makefile.in
EXTRA_DIST = \
- .editorconfig \
- Makefile.common
+ .editorconfig
extcap_PROGRAMS = \
@androiddump_bin@ \
@randpktdump_bin@ \
- @sshdump_bin@ \
+ @sshdump_bin@ \
@ciscodump_bin@
EXTRA_PROGRAMS = androiddump randpktdump sshdump ciscodump
+androiddump_SOURCES = \
+ androiddump.c \
+ extcap-base.c
+
if ENABLE_STATIC
androiddump_LDFLAGS = -Wl,-static -all-static
else
@@ -51,6 +53,10 @@ androiddump_LDADD = \
../wsutil/libwsutil.la \
@GLIB_LIBS@
+randpktdump_SOURCES = \
+ randpktdump.c \
+ extcap-base.c
+
if ENABLE_STATIC
randpktdump_LDFLAGS = -Wl,-static -all-static
else
@@ -59,11 +65,16 @@ endif
# Libraries and plugin flags with which to link randpktdump.
randpktdump_LDADD = \
- ../randpkt_core/librandpkt_core.a \
+ ../randpkt_core/librandpkt_core.a \
../wiretap/libwiretap.la \
../wsutil/libwsutil.la \
@GLIB_LIBS@
+sshdump_SOURCES = \
+ sshdump.c \
+ extcap-base.c \
+ ssh-base.c
+
if ENABLE_STATIC
sshdump_LDFLAGS = -Wl,-static -all-static
else
@@ -77,6 +88,11 @@ sshdump_LDADD = \
@GLIB_LIBS@ \
@LIBSSH_LIBS@
+ciscodump_SOURCES = \
+ ciscodump.c \
+ extcap-base.c \
+ ssh-base.c
+
if ENABLE_STATIC
ciscodump_LDFLAGS = -Wl,-static -all-static
else
@@ -89,3 +105,7 @@ ciscodump_LDADD = \
../wsutil/libwsutil.la \
@GLIB_LIBS@ \
@LIBSSH_LIBS@
+
+noinst_HEADERS = \
+ extcap-base.h \
+ ssh-base.h