summaryrefslogtreecommitdiff
path: root/extcap/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-22 05:49:00 +0000
committerJoão Valverde <j@v6e.pt>2016-03-25 00:16:19 +0000
commita1ed7314137dfa5a96e7600ea1d3c6d127697d59 (patch)
tree59cda41b7e61c97a28eb8b130e49291c930a429b /extcap/Makefile.am
parentb0db6a01a8de15a1eabb4a69135066034761dc2a (diff)
downloadwireshark-a1ed7314137dfa5a96e7600ea1d3c6d127697d59.tar.gz
Add ax_lib_socket_nsl.m4 macro
Add SOCKET_LIBS and NSL_LIBS to global LIBS variables on platforms where it is required. Make configure checks for getaddrinfo/gethostname unconditional, that is handled with #ifdefs if necessary. Change-Id: Ia874038454fb9cf3bdbf8e6fd829f319e331837e Reviewed-on: https://code.wireshark.org/review/14560 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'extcap/Makefile.am')
-rw-r--r--extcap/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/extcap/Makefile.am b/extcap/Makefile.am
index ba5ee694e0..81bcd2b549 100644
--- a/extcap/Makefile.am
+++ b/extcap/Makefile.am
@@ -49,8 +49,7 @@ endif
androiddump_LDADD = \
../wiretap/libwiretap.la \
../wsutil/libwsutil.la \
- @GLIB_LIBS@ \
- @SOCKET_LIBS@
+ @GLIB_LIBS@
if ENABLE_STATIC
randpktdump_LDFLAGS = -Wl,-static -all-static
@@ -63,8 +62,7 @@ randpktdump_LDADD = \
../randpkt_core/librandpkt_core.a \
../wiretap/libwiretap.la \
../wsutil/libwsutil.la \
- @GLIB_LIBS@ \
- @SOCKET_LIBS@
+ @GLIB_LIBS@
if ENABLE_STATIC
sshdump_LDFLAGS = -Wl,-static -all-static
@@ -77,8 +75,7 @@ sshdump_LDADD = \
../wiretap/libwiretap.la \
../wsutil/libwsutil.la \
@GLIB_LIBS@ \
- @LIBSSH_LIBS@ \
- @SOCKET_LIBS@
+ @LIBSSH_LIBS@
if ENABLE_STATIC
ciscodump_LDFLAGS = -Wl,-static -all-static
@@ -91,5 +88,4 @@ ciscodump_LDADD = \
../writecap/libwritecap.a \
../wsutil/libwsutil.la \
@GLIB_LIBS@ \
- @LIBSSH_LIBS@ \
- @SOCKET_LIBS@
+ @LIBSSH_LIBS@