summaryrefslogtreecommitdiff
path: root/plugins/docsis/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-09-16 06:30:03 +0000
committerJörg Mayer <jmayer@loplof.de>2009-09-16 06:30:03 +0000
commit5a2247f5a305782dbdaf1f60f967fae603b8ae56 (patch)
treeae0172647ab0821c4226781416f425f93a315b7c /plugins/docsis/CMakeLists.txt
parent14a4c630fd726c76b5d57bf7179701c7eaafcc4a (diff)
downloadwireshark-5a2247f5a305782dbdaf1f60f967fae603b8ae56.tar.gz
Build a few more plugins
svn path=/trunk/; revision=29942
Diffstat (limited to 'plugins/docsis/CMakeLists.txt')
-rw-r--r--plugins/docsis/CMakeLists.txt103
1 files changed, 103 insertions, 0 deletions
diff --git a/plugins/docsis/CMakeLists.txt b/plugins/docsis/CMakeLists.txt
new file mode 100644
index 0000000000..fb415370ff
--- /dev/null
+++ b/plugins/docsis/CMakeLists.txt
@@ -0,0 +1,103 @@
+# CMakeLists.txt
+#
+# $Id$
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+#
+
+set(DISSECTOR_SRC
+ packet-bintrngreq.c
+ packet-bpkmattr.c
+ packet-bpkmreq.c
+ packet-bpkmrsp.c
+ packet-intrngreq.c
+ packet-dccack.c
+ packet-dccreq.c
+ packet-dccrsp.c
+ packet-dcd.c
+ packet-docsis.c
+ packet-dsaack.c
+ packet-dsareq.c
+ packet-dsarsp.c
+ packet-dscack.c
+ packet-dscreq.c
+ packet-dscrsp.c
+ packet-dsdreq.c
+ packet-dsdrsp.c
+ packet-macmgmt.c
+ packet-map.c
+ packet-mdd.c
+ packet-regack.c
+ packet-regreq.c
+ packet-regreqmp.c
+ packet-regrsp.c
+ packet-regrspmp.c
+ packet-rngreq.c
+ packet-rngrsp.c
+ packet-sync.c
+ packet-tlv.c
+ packet-type29ucd.c
+ packet-uccreq.c
+ packet-uccrsp.c
+ packet-ucd.c
+ packet-vendor.c
+)
+
+set(PLUGIN_FILES
+ plugin.c
+ ${DISSECTOR_SRC}
+)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+ADD_CUSTOM_COMMAND(
+# FIXME: Only the Python stuff has been implemented
+# Make this into a MACRO, to avoid duplication with epan/
+#plugin.c: $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
+# $(top_srcdir)/tools/make-dissector-reg.py
+# @if test -n "$(PYTHON)"; then \
+# echo Making plugin.c with python ; \
+# $(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
+# plugin $(DISSECTOR_SRC) ; \
+# else \
+# echo Making plugin.c with shell script ; \
+# $(top_srcdir)/tools/make-dissector-reg $(srcdir) \
+# $(plugin_src) plugin $(DISSECTOR_SRC) ; \
+# fi
+
+ OUTPUT plugin.c
+ COMMAND ${PYTHON_EXECUTABLE}
+ ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg.py
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ plugin
+ ${DISSECTOR_SRC}
+ DEPENDS
+ ${DISSECTOR_SRC}
+ ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg
+ ${CMAKE_SOURCE_DIR}/tools/make-dissector-reg.py
+)
+
+# todo
+# Do I need any of this or is this handled by type MODULE?
+# asn1_la_LDFLAGS = -module -avoid-version
+
+add_library(docsis MODULE
+ ${PLUGIN_FILES}
+)
+