summaryrefslogtreecommitdiff
path: root/plugins/ethercat/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2010-09-24 20:41:34 +0000
committerGuy Harris <guy@alum.mit.edu>2010-09-24 20:41:34 +0000
commitac3ac6c476d0d92a16db0e840af96ba3e43c68a0 (patch)
treec6918a98de58abd1144cd9002f1a4c3c43dc815c /plugins/ethercat/CMakeLists.txt
parent9ba7c5f9dfc4a067569e1527285a0067845a3375 (diff)
downloadwireshark-ac3ac6c476d0d92a16db0e840af96ba3e43c68a0.tar.gz
Plugins are not shared libraries, so:
1) don't set thei SOVERSION - run-time-loaded modules don't have an SOVERSION; 2) build them with link mode MODULE, not SHARED, on all platforms. (Fixing 1) also fixes the problem with building them as MODULE on OS X.) svn path=/trunk/; revision=34243
Diffstat (limited to 'plugins/ethercat/CMakeLists.txt')
-rw-r--r--plugins/ethercat/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/plugins/ethercat/CMakeLists.txt b/plugins/ethercat/CMakeLists.txt
index dfb4911164..4792f8b604 100644
--- a/plugins/ethercat/CMakeLists.txt
+++ b/plugins/ethercat/CMakeLists.txt
@@ -59,7 +59,6 @@ add_library(ethercat ${LINK_MODE_MODULE}
${PLUGIN_FILES}
)
set_target_properties(ethercat PROPERTIES PREFIX "")
-set_target_properties(ethercat PROPERTIES SOVERSION ${CPACK_PACKAGE_VERSION})
set_target_properties(ethercat PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
target_link_libraries(ethercat epan)