summaryrefslogtreecommitdiff
path: root/plugins/profinet/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-02-09 05:31:15 +0000
committerGuy Harris <guy@alum.mit.edu>2013-02-09 05:31:15 +0000
commite30d2b5001ae68f7d71e20f290f5a6116243994f (patch)
tree2d000509f1b77ca60727b9d7340df7b73128ad80 /plugins/profinet/Makefile.am
parent4aae84271d346f95a68225aefd84207aa4505679 (diff)
downloadwireshark-e30d2b5001ae68f7d71e20f290f5a6116243994f.tar.gz
Make the other plugin makefiles use the new style introduced in the MATE
makefiles. svn path=/trunk/; revision=47579
Diffstat (limited to 'plugins/profinet/Makefile.am')
-rw-r--r--plugins/profinet/Makefile.am22
1 files changed, 13 insertions, 9 deletions
diff --git a/plugins/profinet/Makefile.am b/plugins/profinet/Makefile.am
index 7946d64b9f..4a932e50cb 100644
--- a/plugins/profinet/Makefile.am
+++ b/plugins/profinet/Makefile.am
@@ -22,7 +22,9 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-INCLUDES = -I$(top_srcdir) -I$(includedir)
+include $(top_srcdir)/Makefile.am.inc
+
+INCLUDES = -I$(top_srcdir)
include Makefile.common
@@ -33,12 +35,13 @@ endif
plugindir = @plugindir@
plugin_LTLIBRARIES = profinet.la
+
profinet_la_SOURCES = \
plugin.c \
moduleinfo.h \
- $(DISSECTOR_SRC) \
- $(DISSECTOR_SUPPORT_SRC) \
- $(DISSECTOR_INCLUDES)
+ $(SRC_FILES) \
+ $(HEADER_FILES)
+
profinet_la_LDFLAGS = -module -avoid-version
profinet_la_LIBADD = @PLUGIN_LIBS@
@@ -62,7 +65,7 @@ LIBS =
# preceded only by "void " starting in column zero, and must not be
# inside #if.
#
-# DISSECTOR_SRC is assumed to have all the files that need to be scanned.
+# REGISTER_SRC_FILES is assumed to have all the files that need to be scanned.
#
# For some unknown reason, having a big "for" loop in the Makefile
# to scan all the files doesn't work with some "make"s; they seem to
@@ -80,16 +83,16 @@ LIBS =
# a plugin.c file for a plugin.
# All subsequent arguments are the files to scan.
#
-plugin.c: $(DISSECTOR_SRC) Makefile.common $(top_srcdir)/tools/make-dissector-reg \
+plugin.c: $(REGISTER_SRC_FILES) Makefile.common $(top_srcdir)/tools/make-dissector-reg \
$(top_srcdir)/tools/make-dissector-reg.py
@if test -n "$(PYTHON)"; then \
echo Making plugin.c with python ; \
$(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
- plugin $(DISSECTOR_SRC) ; \
+ plugin $(REGISTER_SRC_FILES) ; \
else \
echo Making plugin.c with shell script ; \
$(top_srcdir)/tools/make-dissector-reg $(srcdir) \
- $(plugin_src) plugin $(DISSECTOR_SRC) ; \
+ $(plugin_src) plugin $(REGISTER_SRC_FILES) ; \
fi
#
@@ -126,4 +129,5 @@ EXTRA_DIST = \
CMakeLists.txt
checkapi:
- $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput -build $(DISSECTOR_SRC) $(DISSECTOR_INCLUDES)
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput -build \
+ $(CLEAN_SRC_FILES) $(CLEAN_HEADER_FILES)