summaryrefslogtreecommitdiff
path: root/plugins/stats_tree/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /plugins/stats_tree/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
downloadwireshark-a16d401b25c85ffb7fde6c46b51cb7048112f885.tar.gz
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'plugins/stats_tree/Makefile.am')
-rw-r--r--plugins/stats_tree/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/plugins/stats_tree/Makefile.am b/plugins/stats_tree/Makefile.am
index fe1f099439..ab1704f907 100644
--- a/plugins/stats_tree/Makefile.am
+++ b/plugins/stats_tree/Makefile.am
@@ -1,5 +1,4 @@
# Makefile.am
-# Automake file for stats_tree Wireshark plugin
#
# Wireshark - Network traffic analyzer
# By Gerald Combs <gerald@wireshark.org>
@@ -18,12 +17,26 @@
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
include ../Makefile.am.inc
+# the name of the plugin
+PLUGIN_NAME = stats_tree
+
+# Non-generated sources
+NONGENERATED_C_FILES = \
+ $(NONGENERATED_REGISTER_C_FILES) \
+ stats_tree_plugin.c \
+ pinfo_stats_tree.c
+
+# Headers.
+CLEAN_HEADER_FILES = \
+ pinfo_stats_tree.h
+
+HEADER_FILES = \
+ $(CLEAN_HEADER_FILES)
+
plugin_LTLIBRARIES = stats_tree.la
stats_tree_la_SOURCES = \
@@ -44,6 +57,5 @@ MAINTAINERCLEANFILES = \
Makefile.in
EXTRA_DIST = \
- Makefile.common \
plugin.rc.in \
CMakeLists.txt