summaryrefslogtreecommitdiff
path: root/plugins/stats_tree/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2005-07-24 10:32:22 +0000
committerGuy Harris <guy@alum.mit.edu>2005-07-24 10:32:22 +0000
commite4f089af5857cab4f2983cf20915b6a5168ebf07 (patch)
tree72c531309effb12e977d9c66a736348f56bf20d7 /plugins/stats_tree/Makefile.am
parent699e51ccdd4e3dbae670ba0fa2e783d874b1a687 (diff)
downloadwireshark-e4f089af5857cab4f2983cf20915b6a5168ebf07.tar.gz
Add "pinfo_stats_tree.h" to declare "register_pinfo_stat_trees()", and
include it in "pinfo_stats_tree.c" (which defines it) and "stats_tree_plugin.c" (which refers to it). Make all the other routines defined in "pinfo_stats_tree.c" static, as they're not used outside "pinfo_stats_tree.c". Get rid of declaration of unused "register_http_stat_trees()". svn path=/trunk/; revision=15035
Diffstat (limited to 'plugins/stats_tree/Makefile.am')
-rw-r--r--plugins/stats_tree/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/stats_tree/Makefile.am b/plugins/stats_tree/Makefile.am
index e4bbf76f62..f1b46882f2 100644
--- a/plugins/stats_tree/Makefile.am
+++ b/plugins/stats_tree/Makefile.am
@@ -27,7 +27,7 @@ INCLUDES = -I$(top_srcdir)
plugindir = @plugindir@
plugin_LTLIBRARIES = stats_tree.la
-stats_tree_la_SOURCES = stats_tree_plugin.c pinfo_stats_tree.c
+stats_tree_la_SOURCES = stats_tree_plugin.c pinfo_stats_tree.c pinfo_stats_tree.h
stats_tree_la_LDFLAGS = -module -avoid-version
stats_tree_la_LIBADD = @PLUGIN_LIBS@