summaryrefslogtreecommitdiff
path: root/tools/pidl/Makefile.PL
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2005-09-19 23:31:47 +0000
committerJörg Mayer <jmayer@loplof.de>2005-09-19 23:31:47 +0000
commit44a4fd449ceebc441d80e9af175dfb8b022f689a (patch)
tree3f9ed2f800fb0c180ea3826749b87066a16a1052 /tools/pidl/Makefile.PL
parent5cee6fb82791533fcb85d57ae7cdf130524baa21 (diff)
downloadwireshark-44a4fd449ceebc441d80e9af175dfb8b022f689a.tar.gz
Revert back to local copy: The samba svn server does not support svn
over http - this was a much requested feature for Ethereals svn server. svn path=/trunk/; revision=15882
Diffstat (limited to 'tools/pidl/Makefile.PL')
-rwxr-xr-xtools/pidl/Makefile.PL25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/pidl/Makefile.PL b/tools/pidl/Makefile.PL
new file mode 100755
index 0000000000..fa250cabc3
--- /dev/null
+++ b/tools/pidl/Makefile.PL
@@ -0,0 +1,25 @@
+use ExtUtils::MakeMaker;
+WriteMakefile(
+ 'NAME' => 'Parse::Pidl',
+ 'VERSION_FROM' => 'lib/Parse/Pidl.pm',
+ 'EXE_FILES' => [ 'pidl' ],
+ 'PMLIBDIRS' => [ 'lib' ],
+ 'test' => { 'TESTS' => 'tests/*.pl' }
+);
+
+sub MY::postamble {
+<<'EOT';
+lib/Parse/Pidl/IDL.pm :: idl.yp
+ yapp -s -m 'Parse::Pidl::IDL' -o 'lib/Parse/Pidl/IDL.pm' idl.yp
+
+doc: pidl.1 pidl.1.html
+
+XSLTPROC=xsltproc
+
+%.1: %.1.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.html: %.xml
+ test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
+EOT
+}