summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2016-03-11 19:51:39 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2016-05-02 12:01:24 +0000
commit2e23b506c766d98966ed213c760b2aa6232ba1fe (patch)
treee15eec1049e10419d869dea459730791ec2bc128 /ui/CMakeLists.txt
parent231f6b5035e4f001eca22029b58cf4c498d624bd (diff)
downloadwireshark-2e23b506c766d98966ed213c760b2aa6232ba1fe.tar.gz
Add checkAPI calls to CMake.
This generates a top level target, checkAPI, that is excluded from the ALL build target, so must be run separately. On Windows using a Visual Studio generator, call msbuild /p:Configuration=RelWithDebInfo checkAPI.vcxproj Change-Id: I44a57c564dcfc75499463b942436f4b920a82478 Reviewed-on: https://code.wireshark.org/review/14873 Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt27
1 files changed, 23 insertions, 4 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index cb6d27df79..f7842b8ce7 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -69,9 +69,7 @@ file(GLOB EXTRA_UI_HEADERS
tap-rtp-analysis.h
)
-set(DIRTY_UI_SRC)
-
-add_lex_files(DIRTY_UI_SRC
+add_lex_files(LEX_FILES GENERATED_FILES
text_import_scanner.l
)
@@ -90,12 +88,33 @@ endif()
add_library(ui STATIC
${COMMON_UI_SRC}
- ${DIRTY_UI_SRC}
+ ${GENERATED_FILES}
)
set_target_properties(ui PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
set_target_properties(ui PROPERTIES FOLDER "UI")
+CHECKAPI(
+ NAME
+ ui-base
+ SWITCHES
+ -g deprecated-gtk
+ SOURCES
+ ${COMMON_UI_SRC}
+# LEX files commented out due to use of malloc, free etc.
+# ${LEX_FILES}
+)
+CHECKAPI(
+ NAME
+ ui-todo
+ SWITCHES
+ -M -g deprecated-gtk-todo
+ SOURCES
+ ${COMMON_UI_SRC}
+# LEX files commented out due to use of malloc, free etc.
+# ${LEX_FILES}
+)
+
#
# Editor modelines - http://www.wireshark.org/tools/modelines.html
#