summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-04-19 19:21:11 -0700
committerGuy Harris <guy@alum.mit.edu>2017-04-20 02:21:58 +0000
commit347a19ae9629ad06ab597a176672c9098c9af64a (patch)
tree859f885bc1280b9e920033562a87b251e84ecf56 /ui/CMakeLists.txt
parent9e8bc9fee87c99944bfe52e27498d759e7235701 (diff)
downloadwireshark-347a19ae9629ad06ab597a176672c9098c9af64a.tar.gz
Add common routines for command-line libwiretap error reporting.
These are similar to the routines added to ui/alert_box.c for dialog-box libwiretap error reporting. This centralizes the knowledge about what to say for various libwiretap errors, removing some duplicate code, and giving more details in some programs. Change-Id: I737405c4edaa0e6c27840f78a8c587a8b3ee120b Reviewed-on: https://code.wireshark.org/review/21234 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index b15a4dcf21..d1f778ee77 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -31,6 +31,7 @@ set(COMMON_UI_SRC
export_object_ui.c
export_pdu_ui_utils.c
help_url.c
+ failure_message.c
filter_files.c
firewall_rules.c
iface_lists.c