summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-04-22 19:00:29 +0000
committerJörg Mayer <jmayer@loplof.de>2013-04-22 19:00:29 +0000
commit8c11433414789e4a920aaad42d19d62a311e0628 (patch)
treed0bbaa192e38c96d8f07df0cb92de3bf3b4cdd08 /ui/CMakeLists.txt
parent679decdac63e80e03c89c04fc55224037bdeec66 (diff)
downloadwireshark-8c11433414789e4a920aaad42d19d62a311e0628.tar.gz
Revert
http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=46575 User: gerald Date: 2012/12/17 01:24 PM Log: Add libui_dirty. This is the autofoo way of solving the problem. Implement the cmake solution (which is used in wiretap/ and other places) which does not require building a separate lib. svn path=/trunk/; revision=48976
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index 971b643f65..14e1ed2c10 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -48,12 +48,11 @@ add_lex_files(DIRTY_UI_SRC
set(CLEAN_FILES
${COMMON_UI_SRC}
- ${DIRTY_UI_SRC}
)
if (WERROR)
set_source_files_properties(
- ${COMMON_UI_SRC}
+ ${CLEAN_FILES}
PROPERTIES
COMPILE_FLAGS -Werror
)
@@ -62,12 +61,7 @@ endif()
add_library(ui STATIC
${COMMON_UI_SRC}
-)
-
-set_target_properties(ui PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
-
-add_library(ui_dirty STATIC
${DIRTY_UI_SRC}
)
-set_target_properties(ui_dirty PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+set_target_properties(ui PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")