summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2016-06-18 16:49:23 -0400
committerAnders Broman <a.broman58@gmail.com>2016-06-19 05:56:45 +0000
commit9b5b4443cf50aa0e5d98d8129a5c65c6c76a838b (patch)
treea481f214d8452490e5cb0c00255e51f442ce8bc2 /ui/CMakeLists.txt
parentdeef1dc1ff22183c0b70ea65775c23c404c641bb (diff)
downloadwireshark-9b5b4443cf50aa0e5d98d8129a5c65c6c76a838b.tar.gz
Refactor command-line handling of GUI options.
Both GTK and Qt both use the same command-line options, so refactor the parsing and (possibly) applying of those arguments to a single location. Ping-Bug: 12546 Change-Id: Ib31e576c509c5d3d21c33d3247640d9f9c68661b Reviewed-on: https://code.wireshark.org/review/16006 Reviewed-by: Michael Mann <mmann78@netscape.net> Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index 8145dd1dee..67ab6e8d5a 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -24,6 +24,7 @@ set(COMMON_UI_SRC
alert_box.c
capture.c
capture_ui_utils.c
+ commandline.c
console.c
decode_as_utils.c
export_object.c