summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-04-23 16:48:17 -0700
committerGuy Harris <guy@alum.mit.edu>2017-04-24 03:38:21 +0000
commite52c95c6c8cdac34eccdba9b49d68a6982685f1a (patch)
treefc479aac517dbee8b5a6a82ea33ec40a482cc248 /ui/CMakeLists.txt
parent751e078d2bc6adf1179de164291eb743abd8732b (diff)
downloadwireshark-e52c95c6c8cdac34eccdba9b49d68a6982685f1a.tar.gz
Move UI-only stuff out of libwireshark.
Packet ranges are used only in the UI; move the packet range stuff into libui. Don't pass a print_args_t structure to libwireshark packet-printing routines, just pass the few parameters they need. Move the declaration of print_args_t into file.h. Change-Id: Icff5991eea7d7d56f33b4716105895263d275bcf Reviewed-on: https://code.wireshark.org/review/21308 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
index d1f778ee77..8a52ef9463 100644
--- a/ui/CMakeLists.txt
+++ b/ui/CMakeLists.txt
@@ -39,6 +39,7 @@ set(COMMON_UI_SRC
language.c
mcast_stream.c
packet_list_utils.c
+ packet_range.c
persfilepath_opt.c
preference_utils.c
profile.c