summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorMoshe Kaplan <me@moshekaplan.com>2016-11-24 09:37:01 -0500
committerMichael Mann <mmann78@netscape.net>2016-12-02 16:07:35 +0000
commit20c57cb298e4f3b7ac66a22fb7477e4cf424a11b (patch)
tree3929a45a2f0df5182af007af697edfa9a55a4634 /ui/Makefile.am
parent9ca313cfbe4993a0a36520d216a3e4282b0b7b99 (diff)
downloadwireshark-20c57cb298e4f3b7ac66a22fb7477e4cf424a11b.tar.gz
Enable exporting objects with tshark
A new "--export-object <protocol>,<destdir>" option is added to tshark. This required refactoring Export Object behavior in all GUIs to give the export object handling to the dissector, rather than the ui layer. Included in the refactoring was fixing some serious memory leaks in Qt Export Object dialog, crash due to memory scope issues in GTK Export Object dialog, and addition sorting column feature in Qt dialog (set up by creating a widget to manage the items that were previously leaking memory) Bug: 9319 Ping-Bug: 13174 Change-Id: I515d7662fa1f150f672b1476716f347ec27deb9b Reviewed-on: https://code.wireshark.org/review/18927 Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Tested-by: Michael Mann <mmann78@netscape.net> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 8359bf7358..3507f9acbd 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -55,12 +55,7 @@ WIRESHARK_UI_SRC = \
console.c \
decode_as_utils.c \
dissect_opts.c \
- export_object.c \
- export_object_dicom.c \
- export_object_http.c \
- export_object_imf.c \
- export_object_smb.c \
- export_object_tftp.c \
+ export_object_ui.c \
export_pdu_ui_utils.c \
firewall_rules.c \
iface_lists.c \
@@ -102,7 +97,7 @@ WIRESHARK_UI_INCLUDES = \
console.h \
decode_as_utils.h \
dissect_opts.h \
- export_object.h \
+ export_object_ui.h \
export_pdu_ui_utils.h \
last_open_dir.h \
file_dialog.h \