summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-27 02:28:17 +0000
committerJoão Valverde <j@v6e.pt>2016-01-28 18:13:48 +0000
commit265a41e14da6b3ebf1e49e726eee62d1372110bf (patch)
treef1a524f8e66ebd43691de84649f231f32ee125f6 /ui/Makefile.am
parent97a1a50e200a6c50e0014dde7e8ec932c30190a1 (diff)
downloadwireshark-265a41e14da6b3ebf1e49e726eee62d1372110bf.tar.gz
autotools: Don't use "user variables" to set build flags
GNU coding standards recommend against it and automake is designed around it. This allows overriding the global build flags using AM_CFLAGS, etc., or per object flags, something that is difficult or impossible currently because of automake precedence rules. Change-Id: I3f1ea12e560af5a46b2f04b342b1882bbf123f12 Reviewed-on: https://code.wireshark.org/review/13455 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 3c33aee04c..80904eb5a2 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -21,11 +21,10 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
include Makefile.common
-include ../Makefile.am.inc
+include $(top_srcdir)/Makefile.am.inc
-if HAVE_WARNINGS_AS_ERRORS
-AM_CLEAN_CFLAGS = -Werror
-endif
+AM_CPPFLAGS += -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
noinst_LIBRARIES = libui.a libui_dirty.a
@@ -39,8 +38,6 @@ MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \
Makefile.in
-RUNLEX=$(top_srcdir)/tools/runlex.sh
-
text_import_scanner_lex.h: text_import_scanner.c
# All sources that should be put in the source distribution tarball
@@ -50,18 +47,14 @@ libui_a_SOURCES = \
$(GENERATED_HEADER_FILES) \
$(GENERATED_C_FILES)
-libui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
-
libui_a_DEPENDENCIES =
libui_dirty_a_SOURCES = \
$(DIRTY_GENERATED_C_FILES)
-libui_dirty_a_DEPENDENCIES =
-
-# Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+libui_dirty_a_CFLAGS = $(GENERATED_CFLAGS)
+libui_dirty_a_DEPENDENCIES =
doxygen:
if HAVE_DOXYGEN