summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2014-04-23 10:50:27 +0200
committerAnders Broman <a.broman58@gmail.com>2014-04-25 04:23:46 +0000
commitbd38b3152d12584b9cd31d0c49706f1cebaa087a (patch)
treedd9ffd4b9f64647e9c683085b0fb73337132a7ab /ui/Makefile.am
parent748e0d4221eabab207a350640ce3f526c73afde9 (diff)
downloadwireshark-bd38b3152d12584b9cd31d0c49706f1cebaa087a.tar.gz
Support out-of-source checkapi
Always call $(top_srcdir)/tools/checkAPIs.pl with -sourcedir=$(srcdir) from Makefile.am to allow out-of-source 'make checkapi'. Change-Id: I60d7e0079984a8ededdacf4517a0738486fa7973 Reviewed-on: https://code.wireshark.org/review/1294 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index 9cff88f696..3c33aee04c 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -76,11 +76,13 @@ endif
checkapi: checkapi-base checkapi-todo
checkapi-base:
- $(PERL) ../tools/checkAPIs.pl -g deprecated-gtk -build \
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g deprecated-gtk -build \
+ -sourcedir=$(srcdir) \
$(WIRESHARK_UI_SRC)
checkapi-todo:
- $(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
+ $(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
+ -sourcedir=$(srcdir) \
$(WIRESHARK_UI_SRC)
EXTRA_DIST = \