summaryrefslogtreecommitdiff
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-02-19 22:25:54 +0000
committerGuy Harris <guy@alum.mit.edu>2012-02-19 22:25:54 +0000
commite79881c8b46c3f4bd9bc39522dd1ed23fa3aee13 (patch)
tree18bbfefc135097fffc40e3f31f91d8739f216914 /ui/Makefile.am
parentec953f91f21450161b9a45a480093a26ae54da54 (diff)
downloadwireshark-e79881c8b46c3f4bd9bc39522dd1ed23fa3aee13.tar.gz
We already have GENERATED_HEADER_FILES; no need for GENERATED_H_FILES.
Remove a bunch of stuff copied over from ui/gtk/Makefile.am that doesn't apply here. There's no DIRTY_GENERATED_C_FILES. svn path=/trunk/; revision=41074
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am51
1 files changed, 7 insertions, 44 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index ebe8e0064c..95044ab1e0 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -39,20 +39,12 @@ MAINTAINERCLEANFILES = \
$(GENERATED_FILES) \
Makefile.in
-RUNLEX=$(top_srcdir)/tools/runlex.sh
-
-text_import_scanner_lex.h: text_import_scanner.c
-
-wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc
- @echo Making wireshark-tap-register.c
- @$(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
-
+# All sources that should be put in the source distribution tarball
libui_a_SOURCES = \
$(WIRESHARK_UI_SRC) \
- $(GENERATED_C_FILES) \
- $(GENERATED_H_FILES) \
$(noinst_HEADERS) \
- $(WIRESHARK_TAP_SRC)
+ $(GENERATED_HEADER_FILES) \
+ $(GENERATED_C_FILES)
libui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
@@ -71,43 +63,14 @@ checkapi: checkapi-base checkapi-todo
checkapi-base:
$(PERL) ../tools/checkAPIs.pl -g deprecated-gtk \
- $(WIRESHARK_UI_SRC) \
- $(WIRESHARK_TAP_SRC) \
- capture_if_details_dlg_win32.c
+ $(WIRESHARK_UI_SRC)
checkapi-todo:
$(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
- $(WIRESHARK_UI_SRC) \
- $(WIRESHARK_TAP_SRC) \
- capture_if_details_dlg_win32.c
-
-expert_indicators.h:
- echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
- echo >> $@
- for elevel in chat error none note warn ; do \
- gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
- done
-
-network_icons.h:
- echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
- echo >> $@
- for icon in bluetooth usb wired wireless ; do \
- gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
- done
-
-remote_icons.h:
- echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
- echo >> $@
- for icon in arrow globe sat ; do \
- gdk-pixbuf-csource --raw --name=remote_$${icon}_pb_data ../image/toolbar/remote_$${icon}_16.png >> $@ ;\
- done
-
-pipe_icon.h:
- echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
- echo >> $@
- gdk-pixbuf-csource --raw --name=pipe_pb_data ../image/toolbar/pipe_16.png >> $@
+ $(WIRESHARK_UI_SRC)
EXTRA_DIST = \
- $(GENERATOR_FILES) \
+ $(GENERATOR_FILES) \
+ doxygen.cfg.in \
Makefile.common \
Makefile.nmake