summaryrefslogtreecommitdiff
path: root/ui/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-09-18 08:05:48 +0200
committerJörg Mayer <jmayer@loplof.de>2014-09-18 07:02:00 +0000
commit3b46e6eaf61a29f9bd8f8c162caa54cc2ea81fe2 (patch)
tree529bfa2bd7e8a0da4b95b392efa9c8a834e04789 /ui/gtk/CMakeLists.txt
parent84629f43cb6c19ca2e0e512ac2429584925be896 (diff)
downloadwireshark-3b46e6eaf61a29f9bd8f8c162caa54cc2ea81fe2.tar.gz
Having CmakeListsCustom.txt in git defeats the purpose of its existence:
If it is used, there is a modified file in git. Fix this by only including the file if it exists. Other changes: - Rename the existing Custom files to CMakeListsCustom.txt.example. - Move the plugins custom file to the top level (same level as its including parent). - Optionally allow a list of custom includes instead of the default one. Change-Id: I8960eac6222f741c045055d43d1d5a2d4979caf6 Reviewed-on: https://code.wireshark.org/review/4163 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'ui/gtk/CMakeLists.txt')
-rw-r--r--ui/gtk/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/ui/gtk/CMakeLists.txt b/ui/gtk/CMakeLists.txt
index 3b5600445e..13878c7770 100644
--- a/ui/gtk/CMakeLists.txt
+++ b/ui/gtk/CMakeLists.txt
@@ -19,7 +19,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
-include(CMakeListsCustom.txt)
+ADD_CUSTOM_CMAKE_INCLUDE()
set(WIRESHARK_GTK_SRC
about_dlg.c