summaryrefslogtreecommitdiff
path: root/ui/gtk/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-09-25 15:37:38 -0700
committerStig Bjørlykke <stig@bjorlykke.org>2014-09-28 18:22:48 +0000
commitefea8ce1c6a4331bc2ff7090dd3dadd2a80f6d86 (patch)
treec88021f39ef9fc00cd05a7cc0afd8afb7f30cb2e /ui/gtk/CMakeLists.txt
parent5517c428839b2682bd040209054c3584c4089b3d (diff)
downloadwireshark-efea8ce1c6a4331bc2ff7090dd3dadd2a80f6d86.tar.gz
CMake: Conditional build fixes and updates.
HAVE_PORTAUDIO_H didn't work for Stig. Use PORTAUDIO_FOUND instead, which is the correct name to use according to the FIND_PACKAGE_HANDLE_STANDARD_ARGS documentation. Use xxx_FOUND in a couple of other places. Conditionally build caputils/airpcap_loader.c. Change-Id: I6a134192902229a446dccf43bfb7bbfe2a55d1e2 Reviewed-on: https://code.wireshark.org/review/4291 Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Stig Bjørlykke <stig@bjorlykke.org> Tested-by: Stig Bjørlykke <stig@bjorlykke.org>
Diffstat (limited to 'ui/gtk/CMakeLists.txt')
-rw-r--r--ui/gtk/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/ui/gtk/CMakeLists.txt b/ui/gtk/CMakeLists.txt
index e27b2da684..92acf2de09 100644
--- a/ui/gtk/CMakeLists.txt
+++ b/ui/gtk/CMakeLists.txt
@@ -117,7 +117,7 @@ set(WIRESHARK_GTK_SRC
${WIRESHARK_CUSTOM_GTK_SRC}
)
-if (HAVE_AIRPCAP)
+if (AIRPCAP_FOUND)
set(WIRESHARK_GTK_SRC
${WIRESHARK_GTK_SRC}
airpcap_dlg.c
@@ -126,14 +126,14 @@ if (HAVE_AIRPCAP)
)
endif()
-if(HAVE_PORTAUDIO_H)
+if(PORTAUDIO_FOUND)
set(WIRESHARK_GTK_SRC
${WIRESHARK_GTK_SRC}
rtp_player.c
)
endif()
-if(HAVE_EXTCAP)
+if(ENABLE_EXTCAP)
set(WIRESHARK_GTK_SRC
${WIRESHARK_GTK_SRC}
extcap_gtk.c