summaryrefslogtreecommitdiff
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2015-11-27 02:28:17 +0000
committerJoão Valverde <j@v6e.pt>2016-01-28 18:13:48 +0000
commit265a41e14da6b3ebf1e49e726eee62d1372110bf (patch)
treef1a524f8e66ebd43691de84649f231f32ee125f6 /ui/gtk/Makefile.am
parent97a1a50e200a6c50e0014dde7e8ec932c30190a1 (diff)
downloadwireshark-265a41e14da6b3ebf1e49e726eee62d1372110bf.tar.gz
autotools: Don't use "user variables" to set build flags
GNU coding standards recommend against it and automake is designed around it. This allows overriding the global build flags using AM_CFLAGS, etc., or per object flags, something that is difficult or impossible currently because of automake precedence rules. Change-Id: I3f1ea12e560af5a46b2f04b342b1882bbf123f12 Reviewed-on: https://code.wireshark.org/review/13455 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am17
1 files changed, 5 insertions, 12 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index ba8e5b0d33..4a2b8121b2 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -20,13 +20,9 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
include Makefile.common
-include ../../Makefile.am.inc
+include $(top_srcdir)/Makefile.am.inc
-if HAVE_WARNINGS_AS_ERRORS
-AM_CLEAN_CFLAGS = -Werror -Wno-error=deprecated-declarations
-endif
-
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(PORTAUDIO_INCLUDES)
+AM_CPPFLAGS += -I$(top_srcdir)/wiretap $(PORTAUDIO_INCLUDES)
CLEANFILES = \
libgtkui.a \
@@ -61,7 +57,10 @@ EXTRA_DIST = \
pixbuf-csource.c \
pixbuf-csource.h
+BUILT_SOURCES =
+
if HAVE_GRESOURCE
+BUILT_SOURCES += wireshark-gresources.h
GENERATED_HEADER_FILES += wireshark-gresources.h
GENERATED_C_FILES += wireshark-gresources.c
else
@@ -75,14 +74,8 @@ libgtkui_a_SOURCES = \
$(noinst_HEADERS) \
$(GENERATED_HEADER_FILES)
-libgtkui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
-
libgtkui_a_DEPENDENCIES =
-if HAVE_GRESOURCE
-main.c: wireshark-gresources.h
-endif
-
#
# Build "wireshark-tap-register.c", which contains a function
# "register_all_tap_listeners()"