summaryrefslogtreecommitdiff
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-18 17:31:09 +0000
committerJoão Valverde <j@v6e.pt>2016-03-21 17:10:21 +0000
commit52dd4fb6330a10ed37b8e221c502b5a98de4f581 (patch)
tree9d3ea5b26003115f61ac5af0d9dd7997cbe7cfb2 /ui/gtk/Makefile.am
parent69d348c12a2d86e5fa75189cd2dd5f4f3784dcfc (diff)
downloadwireshark-52dd4fb6330a10ed37b8e221c502b5a98de4f581.tar.gz
Fix building without extcap enabled
Using cmake -DENABLE_EXTCAP=no or ./configure --without-extcap. Some documentation fixes too. Change-Id: Iebf9c843d67e10a32de1a62904de8f88b872ec99 Reviewed-on: https://code.wireshark.org/review/14522 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 7a97c0afaa..a2fab6fc5b 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -32,6 +32,11 @@ BUILD_PIXBUF_CSOURCE = \
pixbuf-csource.c
endif
+if HAVE_EXTCAP
+WIRESHARK_COMMON_GTK_SRC += extcap_gtk.c
+WIRESHARK_COMMON_GTK_HDRS += extcap_gtk.h
+endif
+
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GTK_CFLAGS) \
$(PORTAUDIO_INCLUDES)