summaryrefslogtreecommitdiff
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2012-04-04 20:46:49 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2012-04-04 20:46:49 +0000
commit75c3c92f197406d14eb213e30a07955928517399 (patch)
tree6ec908c62bfc2115e32c3e747e90ad14f3552744 /ui/gtk/Makefile.am
parent02e0b847f15c5045bbf15b13d555c619fc8b36c9 (diff)
downloadwireshark-75c3c92f197406d14eb213e30a07955928517399.tar.gz
Add a "-build" argument to checkAPIs.pl. Use that argument when building
from makefiles (and thus from the buildbot). The intention is to be able to tell when a human is running the tool so we can provide more code-review guidance. As a starter, enable the "too many proto_tree_add_text() calls" check when a human is running the tool. svn path=/trunk/; revision=41943
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index a7b6316d84..4294a8f860 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -92,12 +92,12 @@ endif # HAVE_DOXYGEN
checkapi: checkapi-base checkapi-todo
checkapi-base:
- $(PERL) ../../tools/checkAPIs.pl -g deprecated-gtk \
+ $(PERL) ../../tools/checkAPIs.pl -g deprecated-gtk -build \
$(WIRESHARK_CLEAN_LIBGTKUI_SRC) \
capture_if_details_dlg_win32.c
checkapi-todo:
- $(PERL) ../../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
+ $(PERL) ../../tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
$(WIRESHARK_GTK_SRC) \
$(WIRESHARK_TAP_SRC) \
capture_if_details_dlg_win32.c