summaryrefslogtreecommitdiff
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-13 21:19:10 +0000
committerAnders Broman <a.broman58@gmail.com>2016-03-15 05:06:57 +0000
commit8b8253b8ad40ba429f28c02ac987dfb7e4d0df4f (patch)
tree23c3ca6a0b752f272fc1dc1b98b2a163522e5db4 /ui/gtk/Makefile.am
parent54fc0046cb87405f1b650c3c10ae6701d8d00505 (diff)
downloadwireshark-8b8253b8ad40ba429f28c02ac987dfb7e4d0df4f.tar.gz
GTK: Revert most of g11b058e
Don't distribute gresource, it's redundant binary data, make the distribution more similar to Qt instead. We may want to check that glib-compile-resources is in the PATH during configure. Change-Id: I82c57f8169be0cbcac14d4ca79df8dece6c4d7ff Reviewed-on: https://code.wireshark.org/review/14455 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am38
1 files changed, 14 insertions, 24 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 61457a4862..7a97c0afaa 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -22,21 +22,14 @@
include Makefile.common
include $(top_srcdir)/Makefile.am.inc
-#
-# The gresource files are part of the distribution tarball (but can be rebuilt
-# using glib-compile-resources). They're not checked in to the VCS tree.
-# The pixbuf-csource files are also generated files but they're (currently)
-# checked in to the VCS tree. From the point of view of the build system
-# they're not considered generated source (they are never to be cleaned).
-# Finally 'wireshark-tap-register.c' is generated source not part of the
-# distribution tarball. It has no external dependencies and is to be built
-# during compilation.
-#
-
if HAVE_GRESOURCE_PIXBUF
-LIBGTKUI_PIXBUF_SRC = wireshark-gresources.h wireshark-gresources.c
+NODIST_GENERATED_FILES += \
+ wireshark-gresources.h \
+ wireshark-gresources.c
else
-LIBGTKUI_PIXBUF_SRC = pixbuf-csource.h pixbuf-csource.c
+BUILD_PIXBUF_CSOURCE = \
+ pixbuf-csource.h
+ pixbuf-csource.c
endif
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GTK_CFLAGS) \
@@ -49,11 +42,10 @@ CLEANFILES = \
*~
DISTCLEANFILES = \
- $(GENERATED_FILES)
+ $(NODIST_GENERATED_FILES)
MAINTAINERCLEANFILES = \
- wireshark-gresources.h \
- wireshark-gresources.c \
+ $(GENERATED_FILES) \
Makefile.in
EXTRA_DIST = \
@@ -75,11 +67,9 @@ EXTRA_DIST = \
pixbuf-csource.c \
pixbuf-csource.h
-BUILT_SOURCES =
-
-if HAVE_GRESOURCE_PIXBUF
-BUILT_SOURCES += $(LIBGTKUI_PIXBUF_SRC)
-endif
+BUILT_SOURCES = \
+ $(GENERATED_FILES) \
+ $(NODIST_GENERATED_FILES)
noinst_LIBRARIES = libgtkui.a
@@ -87,11 +77,11 @@ libgtkui_a_SOURCES = \
$(WIRESHARK_COMMON_GTK_SRC) \
$(WIRESHARK_COMMON_GTK_HDRS) \
$(WIRESHARK_TAP_SRC) \
- $(LIBGTKUI_PIXBUF_SRC)
+ $(GENERATED_FILES)
nodist_libgtkui_a_SOURCES = \
- $(GENERATED_C_FILES) \
- $(GENERATED_HEADER_FILES)
+ $(NODIST_GENERATED_FILES) \
+ $(BUILD_PIXBUF_CSOURCE)
libgtkui_a_DEPENDENCIES =