summaryrefslogtreecommitdiff
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-03-18 10:34:41 -0700
committerGerald Combs <gerald@wireshark.org>2016-03-28 16:27:41 +0000
commit6931f581f90d272474b47d4a4606bb93183f449a (patch)
tree08ff02c43d1896ea1d5e14bf28cd9288156e91c8 /ui/qt/CMakeLists.txt
parent7e5dae90d65ed062f2d01c63174cc1c94850a19a (diff)
downloadwireshark-6931f581f90d272474b47d4a4606bb93183f449a.tar.gz
Qt: Make conversation menu items static.
Add a ConversationAction and ColorizeAction classes which respectively handle conversation filtering and colorization. Move conversation menu initialization to initConversationMenus and call it once at startup. This keeps us from leaking quite a bit of memory each time we select a packet or proto tree item. Bug: 12044 Change-Id: I32e8cedaba08a419d5da6a7a9db31c910909f450 Reviewed-on: https://code.wireshark.org/review/14516 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index b3f409421e..3b56e65dea 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -45,6 +45,7 @@ set(WIRESHARK_QT_HEADERS
column_preferences_frame.h
column_editor_frame.h
compiled_filter_output.h
+ conversation_colorize_action.h
conversation_dialog.h
conversation_hash_tables_dialog.h
decode_as_dialog.h
@@ -199,6 +200,7 @@ set(WIRESHARK_QT_SRC
column_preferences_frame.cpp
column_editor_frame.cpp
compiled_filter_output.cpp
+ conversation_colorize_action.cpp
conversation_dialog.cpp
conversation_hash_tables_dialog.cpp
decode_as_dialog.cpp