summaryrefslogtreecommitdiff
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-11-12 14:24:16 -0800
committerGerald Combs <gerald@wireshark.org>2014-12-09 19:02:41 +0000
commitbcaa5d84b1e6637927faf6066d6e57a92c94146e (patch)
tree40fec9b3acb8e127708819c7a0ab0d83f5ad099c /ui/qt/CMakeLists.txt
parent9681bddaa60fd7cdfdba00ebd87903a860c4166c (diff)
downloadwireshark-bcaa5d84b1e6637927faf6066d6e57a92c94146e.tar.gz
Qt: Update and rename the summary dialog.
Go back to a single view similar to the GTK+ UI. Apply layouts using Qt Designer. Rename the menu item and class to "Capture File Properties". It's not really a summary if it contains details such as "marked average bits per second". We might want to move this to a "Properties" item under the "File" menu similar to other applications. Add the GTK+ summary icon (for now) to the toolbar and open the properties dialog on clicking. Singleton dialogs delenda est[1]. Let the user open as many summaries on as many capture files as he or she wishes. Also, global cfile delenda est[2]. Don't blindly include QtGui. Add specific components instead. Use consistent method names, variable names, and patterns. Try to document what "consistent" means. Adjust the way we display some statistics to match the summary bar, e.g. displayed = captured if we don't have a filter applied. [1] Not really. [2] Yes, really. Change-Id: I11793b1d79dd0c3f70414ac8592b86181da59916 Reviewed-on: https://code.wireshark.org/review/5274 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index dc01df4f08..dcd553c261 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -27,6 +27,7 @@ set(WIRESHARK_QT_HEADERS
byte_view_tab.h
byte_view_text.h
capture_file_dialog.h
+ capture_file_properties_dialog.h
capture_filter_combo.h
capture_filter_edit.h
capture_filter_syntax_worker.h
@@ -91,7 +92,6 @@ set(WIRESHARK_QT_HEADERS
simple_dialog.h
splash_overlay.h
stats_tree_dialog.h
- summary_dialog.h
syntax_line_edit.h
tcp_stream_dialog.h
time_shift_dialog.h
@@ -122,6 +122,7 @@ set(WIRESHARK_QT_SRC
byte_view_tab.cpp
byte_view_text.cpp
capture_file_dialog.cpp
+ capture_file_properties_dialog.cpp
capture_filter_combo.cpp
capture_filter_edit.cpp
capture_filter_syntax_worker.cpp
@@ -188,7 +189,6 @@ set(WIRESHARK_QT_SRC
splash_overlay.cpp
sparkline_delegate.cpp
stock_icon.cpp
- summary_dialog.cpp
syntax_line_edit.cpp
tcp_stream_dialog.cpp
time_shift_dialog.cpp
@@ -223,8 +223,9 @@ set(DIRTY_FILES
set(WIRESHARK_QT_UI
about_dialog.ui
- capture_preferences_frame.ui
+ capture_file_properties_dialog.ui
capture_interfaces_dialog.ui
+ capture_preferences_frame.ui
column_preferences_frame.ui
compiled_filter_output.ui
decode_as_dialog.ui
@@ -262,7 +263,6 @@ set(WIRESHARK_QT_UI
sequence_dialog.ui
splash_overlay.ui
stats_tree_dialog.ui
- summary_dialog.ui
tcp_stream_dialog.ui
time_shift_dialog.ui
traffic_table_dialog.ui