summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-12 19:10:59 +0000
committerJoão Valverde <j@v6e.pt>2016-03-18 00:58:06 +0000
commit0ebb4912f931eba3a1a23559a1d332fca1b7de95 (patch)
tree8f11b6307d0d2f79de06f1beb23293f00dea453b /ui/qt/Makefile.am
parente7a24dc48415d06598194d0f486eb905c3a86bc9 (diff)
downloadwireshark-0ebb4912f931eba3a1a23559a1d332fca1b7de95.tar.gz
autotools: Generate Qt Resource Compiler source in /ui/qt dir
Change-Id: I0acdc1ea4d2110111a5506104e5075962f580bd5 Reviewed-on: https://code.wireshark.org/review/14438 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am33
1 files changed, 24 insertions, 9 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 5683b06715..8c0c6b47e6 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -31,7 +31,7 @@ CLEANFILES = \
wireshark-tap-register.c-tmp \
wireshark-tap-register-cache.pkl \
*.moc.cpp \
- *.rrc.cpp \
+ qrc_*.cpp \
ui_*.h
*~
@@ -93,22 +93,37 @@ am__v_UIC_0 = @echo " UIC " $@;
# building .rcc.cpp files from .qrc files by running rcc,
# and building ui_XXX.h files from .ui files by running uic.
#
-SUFFIXES = .moc.cpp .qrc .rcc.cpp
+SUFFIXES = .moc.cpp
+#
+# The Qt toolchain uses the naming convention moc_FOO.cpp. Should we do the same?
+#moc_%.cpp: %.h
+# $(MOC) $< -o $@
+#
.h.moc.cpp:
$(AM_V_MOC)$(MOC) $(MOC_OPTIONS) -I.. -I../.. -o $@ $<
-.qrc.rcc.cpp:
- $(MKDIR_P) $(@D)
- $(AM_V_RCC)$(RCC) -name `basename $< .qrc` -o $@ $<
+qrc_about.cpp: ../../image/about.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name about -o $@ $<
+
+qrc_layout.cpp: ../../image/layout.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name layout -o $@ $<
+
+qrc_languages.cpp: ../../image/languages/languages.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name languages -o $@ $<
+
+qrc_i18n.cpp: i18n.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name i18n -o $@ $<
+
+qrc_toolbar.cpp: ../../image/toolbar.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name toolbar -o $@ $<
+
+qrc_wsicon.cpp: ../../image/wsicon.qrc
+ $(AM_V_RCC)$(RCC) $(RCC_OPTIONS) --name wsicon -o $@ $<
ui_%.h: %.ui
$(AM_V_UIC)$(UIC) $< -o $@
-# The Qt toolchain uses the naming convention moc_FOO.cpp. Should we do the same?
-#moc_%.cpp: %.h
-# $(MOC) $< -o $@
-
#
# Explicit dependencies to force the ui_ headers to be built.
# See "Recording Dependencies manually" in the "Built Sources"