summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-08-06 10:07:42 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-05 01:06:53 +0000
commit30f3d524411445c26418c757ac9deb0940afc409 (patch)
treed60cadae8fdfb0612ee6e00bc5f17b550534af29 /ui/qt/Makefile.am
parent382815d6bdd9a66421ae2e07c734df4c8a4ac398 (diff)
downloadwireshark-30f3d524411445c26418c757ac9deb0940afc409.tar.gz
Qt: Refactor ConversationDialog for endpoints.
Create a TrafficTableDialog (for lack of a better name) parent class from the general parts of ConversationDialog. Use it to create EndpointsDialog. Move the contents of conversation_tree_widget.{cpp,h} to conversation_dialog.{cpp,h} to match endpoint_dialog and traffic_table_dialog. Fill in GeoIP columns dynamically instead of using a hard-coded limit. Use "endp_" and "ENDP_" prefixes for a lot of endpoint variables and defines. Try to make geoip_db_lookup_ipv4 and geoip_db_lookup_ipv6 more robust. Clean up some includes. Fix a shadowed variable. Change-Id: I23054816ac7f8c6edb3b1f01c8536db37ba4122d Reviewed-on: https://code.wireshark.org/review/3462 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 668bcb3e67..b325a31fcc 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -130,8 +130,6 @@ column_preferences_frame.cpp column_preferences_frame.h: ui_column_preferences_f
compiled_filter_output.cpp compiled_filter_output.h: ui_compiled_filter_output.h
-conversation_dialog.cpp conversation_dialog.h: ui_conversation_dialog.h
-
decode_as_dialog.cpp decode_as_dialog.h: ui_decode_as_dialog.h
export_object_dialog.cpp export_object_dialog.h: ui_export_object_dialog.h
@@ -212,6 +210,8 @@ tcp_stream_dialog.cpp: ui_tcp_stream_dialog.h
time_shift_dialog.cpp time_shift_dialog.h: ui_time_shift_dialog.h
+traffic_table_dialog.cpp traffic_table_dialog.h: ui_traffic_table_dialog.h
+
uat_dialog.cpp uat_dialog.h: ui_uat_dialog.h
doxygen: