summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-03-17 00:51:08 +0100
committerPeter Wu <peter@lekensteyn.nl>2017-03-24 23:02:43 +0000
commit370f3b358cd9ee7dcd2b7274f7ee6c90d5906c7a (patch)
treef71b56580079e13f017bda7e6c504e30eaa61be8 /ui/qt/Makefile.am
parentb4bc6c72c79fa121753cf94ae179ea73f1e911dd (diff)
downloadwireshark-370f3b358cd9ee7dcd2b7274f7ee6c90d5906c7a.tar.gz
Qt: add cache proxy model for Voip Calls dialog
When a capture file is reloaded, the information stored in VoipCallsInfoModel is invalidated. Add another cache layer to fix this: VoipCallsInfoModel wraps around raw data (invalid on close) CacheProxyModel NEW: use prev. data or cache on close VoipCallsInfoSortedModel provided sorting, etc. VoipCallsDialog actual user of model (callTreeView) This also fixes a UAF after a file was closed, and when a call is selected (that got worse with the last model/view patch and is "fixed" in this patch with the caching layer. Note that the Flow sequence and Play Streams dialog are not that useful when the file is closed). Change-Id: Ib4daff9dc01a54863fe1d943bdbdb876418924ee Reviewed-on: https://code.wireshark.org/review/20574 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index a6ad706a55..846774141f 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -163,6 +163,7 @@ MOC_HDRS = \
bluetooth_hci_summary_dialog.h \
byte_view_tab.h \
byte_view_text.h \
+ cache_proxy_model.h \
capture_file.h \
capture_file_dialog.h \
capture_file_properties_dialog.h \
@@ -449,6 +450,7 @@ WIRESHARK_QT_SRC = \
bluetooth_hci_summary_dialog.cpp \
byte_view_tab.cpp \
byte_view_text.cpp \
+ cache_proxy_model.cpp \
capture_file.cpp \
capture_file_dialog.cpp \
capture_file_properties_dialog.cpp \