summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-03-18 17:31:09 +0000
committerJoão Valverde <j@v6e.pt>2016-03-21 17:10:21 +0000
commit52dd4fb6330a10ed37b8e221c502b5a98de4f581 (patch)
tree9d3ea5b26003115f61ac5af0d9dd7997cbe7cfb2 /ui/qt/Makefile.am
parent69d348c12a2d86e5fa75189cd2dd5f4f3784dcfc (diff)
downloadwireshark-52dd4fb6330a10ed37b8e221c502b5a98de4f581.tar.gz
Fix building without extcap enabled
Using cmake -DENABLE_EXTCAP=no or ./configure --without-extcap. Some documentation fixes too. Change-Id: Iebf9c843d67e10a32de1a62904de8f88b872ec99 Reviewed-on: https://code.wireshark.org/review/14522 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 33c0231ef4..9940f270f8 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -43,6 +43,26 @@ MAINTAINERCLEANFILES = \
$(NODIST_GENERATED_FILES) \
Makefile.in
+if HAVE_EXTCAP
+NODIST_GENERATED_HEADER_FILES += \
+ ui_extcap_options_dialog.h
+
+MOC_HDRS += \
+ extcap_argument.h \
+ extcap_argument_file.h \
+ extcap_argument_multiselect.h \
+ extcap_options_dialog.h
+
+UI_FILES += \
+ extcap_options_dialog.ui
+
+WIRESHARK_QT_SRC += \
+ extcap_argument.cpp \
+ extcap_argument_file.cpp \
+ extcap_argument_multiselect.cpp \
+ extcap_options_dialog.cpp
+endif
+
#
# Build "wireshark-tap-register.c", which contains a function
# "register_all_tap_listeners()"