summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorRoland Knall <rknall@gmail.com>2016-10-17 15:01:24 +0200
committerAnders Broman <a.broman58@gmail.com>2016-10-19 07:43:45 +0000
commit864f750be560a7a739c7453f19a8f5679cf7d6b3 (patch)
treee7d4c74c127a477c13f70ee69c82c6f06274f9a1 /ui/qt/Makefile.am
parent5cbdbecc35f77c40142e2e5389e553931490eea0 (diff)
downloadwireshark-864f750be560a7a739c7453f19a8f5679cf7d6b3.tar.gz
ManageInterfacesDialog: Implement View/Data Model
Implement the same interface view/data model as used for the interface_tree selection in this dialog, to encapsulate all access to global_capture_devices from the dialog. Change-Id: I0e568fe236d077befa2a79765638db8bb3ed1a3f Reviewed-on: https://code.wireshark.org/review/18062 Petri-Dish: Roland Knall <rknall@gmail.com> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 41ceee767e..53d042666e 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -211,6 +211,7 @@ MOC_HDRS = \
import_text_dialog.h \
interface_frame.h \
interface_tree_model.h \
+ interface_tree_cache_model.h \
interface_sort_filter_model.h \
io_graph_dialog.h \
label_stack.h \
@@ -486,6 +487,7 @@ WIRESHARK_QT_SRC = \
import_text_dialog.cpp \
interface_frame.cpp \
interface_tree_model.cpp \
+ interface_tree_cache_model.cpp \
interface_sort_filter_model.cpp \
label_stack.cpp \
layout_preferences_frame.cpp \