summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Smith <whydoubt@gmail.com>2015-08-28 00:21:01 -0500
committerJeff Morriss <jeff.morriss.ws@gmail.com>2015-09-10 13:00:34 +0000
commita2fec2188654bd80ae8567862c546c33bf5eb698 (patch)
tree838c81f092000fecea422df024a208a6ccf2cb4a /ui/qt/Makefile.am
parent5eee0b9e4459ab95083524bc1d430524e63f44d2 (diff)
downloadwireshark-a2fec2188654bd80ae8567862c546c33bf5eb698.tar.gz
Check if -fPIC is needed for Qt5 code to compile
On many systems, Qt5 requires that code compiled against it must compile with -fPIC. The preferred place to determine whether this is necessary is at configure time. This change adds the auto-tool code to make that happen and removes the hack put in place as an interim solution. Bug: 11230 Change-Id: I6e583c67bb67d168a30c0af05a8cd0a070522ba0 Reviewed-on: https://code.wireshark.org/review/10281 Petri-Dish: Jeff Morriss <jeff.morriss.ws@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 16de1ab5dd..e3df64d4a4 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -84,7 +84,7 @@ libqtui_a_DEPENDENCIES =
# Common headers
AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) \
- $(LIBGNUTLS_CFLAGS) $(PIE_CFLAGS)
+ $(LIBGNUTLS_CFLAGS)
AM_CXXFLAGS = $(AM_CLEAN_CFLAGS)