summaryrefslogtreecommitdiff
path: root/ui/qt/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-12-31 19:07:38 +0000
committerGerald Combs <gerald@wireshark.org>2012-12-31 19:07:38 +0000
commitb6382033e1fdd952b34661486156631b1d8d19ae (patch)
tree75bedbe9fe8845466dad83ec9d6e948eebb386e7 /ui/qt/Makefile.am
parentc2a63d4c368f5ade87ff049c51ae9321451224c3 (diff)
downloadwireshark-b6382033e1fdd952b34661486156631b1d8d19ae.tar.gz
It might help for the Qt version of Wireshark to link against the Qt
libraries and to have a main() function. Replace some manual Makefile rules with an implicit rule. svn path=/trunk/; revision=46875
Diffstat (limited to 'ui/qt/Makefile.am')
-rw-r--r--ui/qt/Makefile.am58
1 files changed, 31 insertions, 27 deletions
diff --git a/ui/qt/Makefile.am b/ui/qt/Makefile.am
index 640abebf19..ce30690abb 100644
--- a/ui/qt/Makefile.am
+++ b/ui/qt/Makefile.am
@@ -76,70 +76,74 @@ SUFFIXES = .moc.cpp .qrc .rcc.cpp
.qrc.rcc.cpp:
rcc -name `basename $< .qrc` -o $@ $<
-export_object_dialog.cpp export_object_dialog.h: ui_export_object_dialog.h
-
-ui_export_object_dialog.h: export_object_dialog.ui
+ui_%.h: %.ui
uic $< -o $@
+# The Qt toolchain uses the naming convention moc_FOO.cpp. Should we do the same?
+#moc_%.cpp: %.h
+# moc $< -o $@
+
+export_object_dialog.cpp export_object_dialog.h: ui_export_object_dialog.h
+
file_set_dialog.cpp file_set_dialog.h: ui_file_set_dialog.h
-ui_file_set_dialog.h: file_set_dialog.ui
- uic $< -o $@
+#ui_file_set_dialog.h: file_set_dialog.ui
+# uic $< -o $@
import_text_dialog.cpp import_text_dialog.h: ui_import_text_dialog.h
-ui_import_text_dialog.h: import_text_dialog.ui
- uic $< -o $@
+#ui_import_text_dialog.h: import_text_dialog.ui
+# uic $< -o $@
main_welcome.cpp main_welcome.h: ui_main_welcome.h
-ui_main_welcome.h: main_welcome.ui
- uic $< -o $@
+#ui_main_welcome.h: main_welcome.ui
+# uic $< -o $@
main_window.cpp main_window.h: ui_main_window.h
-ui_main_window.h: main_window.ui
- uic $< -o $@
+#ui_main_window.h: main_window.ui
+# uic $< -o $@
packet_comment_dialog.cpp packet_comment_dialog.h: ui_packet_comment_dialog.h
-ui_packet_comment_dialog.h: packet_comment_dialog.ui
- uic $< -o $@
+#ui_packet_comment_dialog.h: packet_comment_dialog.ui
+# uic $< -o $@
packet_format_group_box.cpp packet_format_group_box.h: ui_packet_format_group_box.h
-ui_packet_format_group_box.h: packet_format_group_box.ui
- uic $< -o $@
+#ui_packet_format_group_box.h: packet_format_group_box.ui
+# uic $< -o $@
packet_range_group_box.cpp packet_range_group_box.h: ui_packet_range_group_box.h
-ui_packet_range_group_box.h: packet_range_group_box.ui
- uic $< -o $@
+#ui_packet_range_group_box.h: packet_range_group_box.ui
+# uic $< -o $@
print_dialog.cpp print_dialog.h: ui_print_dialog.h
-ui_print_dialog.h: print_dialog.ui
- uic $< -o $@
+#ui_print_dialog.h: print_dialog.ui
+# uic $< -o $@
profile_dialog.cpp profile_dialog.h: ui_profile_dialog.h
-ui_profile_dialog.h: profile_dialog.ui
- uic $< -o $@
+#ui_profile_dialog.h: profile_dialog.ui
+# uic $< -o $@
search_frame.cpp search_frame.h: ui_search_frame.h
-ui_search_frame.h: search_frame.ui
- uic $< -o $@
+#ui_search_frame.h: search_frame.ui
+# uic $< -o $@
splash_overlay.cpp splash_overlay.h: ui_splash_overlay.h
-ui_splash_overlay.h: splash_overlay.ui
- uic $< -o $@
+#ui_splash_overlay.h: splash_overlay.ui
+# uic $< -o $@
time_shift_dialog.cpp time_shift_dialog.h: ui_time_shift_dialog.h
-ui_time_shift_dialog.h: time_shift_dialog.ui
- uic $< -o $@
+#ui_time_shift_dialog.h: time_shift_dialog.ui
+# uic $< -o $@
doxygen:
if HAVE_DOXYGEN