summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@zing.org>2014-10-09 18:24:18 -0700
committerGerald Combs <gerald@wireshark.org>2014-10-10 01:45:55 +0000
commit3a4cab751ee59881f8ae0963dffc4ee82e36f085 (patch)
treec3e378890c7c3716f3fb288d6d33f16f1737fa95 /wiretap/CMakeLists.txt
parent33d20c64dcc772118fd27f09a129a76416876beb (diff)
downloadwireshark-3a4cab751ee59881f8ae0963dffc4ee82e36f085.tar.gz
CMake: Bundle our libraries.
Change-Id: I5df4d794602f7e53c2f4f496597f8eaf7c7b6eaa Reviewed-on: https://code.wireshark.org/review/4588 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index b2687f1300..571831fcbd 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -127,6 +127,12 @@ IF(MSVC)
set_target_properties(wiretap PROPERTIES OUTPUT_NAME "wiretap-${PROJECT_VERSION}")
ENDIF()
+if(ENABLE_APPLICATION_BUNDLE)
+ set_target_properties(wiretap PROPERTIES
+ LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/run/Wireshark.app/Contents/Frameworks
+ )
+endif()
+
ABICHECK(libwiretap)
add_custom_command(OUTPUT libwiretap.abi.tar.gz
@@ -145,4 +151,3 @@ if(NOT ${ENABLE_STATIC})
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
endif()
-