summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2016-09-30 16:06:15 +0200
committerDario Lombardo <lomato@gmail.com>2016-09-30 20:08:02 +0000
commit534787e402d6aa8b349638f911a2a65b013c6594 (patch)
tree9cfaeb38a16eab0fee86b3b0fb8f9245c7813f7a /wiretap/CMakeLists.txt
parent53c91974c7e8f77555920e137cab80b5418e992b (diff)
downloadwireshark-534787e402d6aa8b349638f911a2a65b013c6594.tar.gz
cmake: make WERROR_COMMON_FLAGS a normal string
Instead of checking for the boolean "FALSE", just set an empty string. This avoids the need to check for WERROR_COMMON_FLAGS before using it. The transformation is the same for all files, remove "if (WERROR_COMMON_FLAGS)" and "endif()", reindent and add quotes (since we have a string here and not a list). Modelines have been added where missing. Change-Id: I0ab05ae507c51fa77336d49a99a226399cc81b92 Reviewed-on: https://code.wireshark.org/review/17997 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Dario Lombardo <lomato@gmail.com> Tested-by: Dario Lombardo <lomato@gmail.com>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt25
1 files changed, 18 insertions, 7 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index bb89c5c4fb..5ff2f1ef39 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -84,13 +84,11 @@ set(WIRETAP_FILES
${CMAKE_SOURCE_DIR}/ws_version_info.c
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${WIRETAP_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${WIRETAP_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
add_lex_files(LEX_FILES GENERATED_FILES
ascend_scanner.l
@@ -168,3 +166,16 @@ CHECKAPI(
# ${LEX_FILES}
${YACC_FILES}
)
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#