summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2016-06-21 15:31:39 +0200
committerMichael Mann <mmann78@netscape.net>2016-06-22 23:57:01 +0000
commit63027fce6e11e645865607cf4124eb8cfb4c3609 (patch)
tree4fe397e04757635d2b09f1fc5dbce83a82975f57 /wiretap/CMakeLists.txt
parenta9a306f0a1fa09cb3f5e72f17524885cd5bf6d95 (diff)
downloadwireshark-63027fce6e11e645865607cf4124eb8cfb4c3609.tar.gz
Windows: rename wiretap-${PROJECT_VERSION}.dll to libwiretap.dll
This aligns the name with what is done for other Wireshark shared libraries. Moreover it allows to compile a wiretap plugin once per major release, without the need to recompile it each time ${PROJECT_VERSION} changes (each nightly build / official release). Change-Id: I53c82277223a4f323079cf695168ac85c2fba523 Reviewed-on: https://code.wireshark.org/review/16058 Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com> Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 60c8a1e349..871b05f00f 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -119,14 +119,12 @@ add_dependencies(wiretap version)
set(FULL_SO_VERSION "0.0.0")
set_target_properties(wiretap PROPERTIES
+ PREFIX "lib"
COMPILE_DEFINITIONS "WS_BUILD_DLL"
LINK_FLAGS "${WS_LINK_FLAGS}"
VERSION ${FULL_SO_VERSION} SOVERSION 0
FOLDER "DLLs"
)
-IF(MSVC)
- set_target_properties(wiretap PROPERTIES OUTPUT_NAME "wiretap-${PROJECT_VERSION}")
-ENDIF()
if(ENABLE_APPLICATION_BUNDLE)
set_target_properties(wiretap PROPERTIES