summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorBalint Reczey <balint@balintreczey.hu>2013-10-15 07:30:05 +0000
committerBalint Reczey <balint@balintreczey.hu>2013-10-15 07:30:05 +0000
commit8956ee2a567e2e2e4d8b8704d80beb9cde6678b1 (patch)
tree51cf19e31d2856428b0195e4b131435c93c9536a /wiretap/CMakeLists.txt
parent66de01339985521b2b69fcfcb4cd0587dea63fba (diff)
downloadwireshark-8956ee2a567e2e2e4d8b8704d80beb9cde6678b1.tar.gz
Factor out common parts of ABI checks to UseABICheck.cmake
svn path=/trunk/; revision=52614
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 7fc2275da5..b5f9e9c4da 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -21,6 +21,7 @@
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+include(UseABICheck)
set(CLEAN_FILES
5views.c
@@ -121,20 +122,7 @@ set_target_properties(wiretap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
set_target_properties(wiretap PROPERTIES VERSION ${FULL_SO_VERSION} SOVERSION 0)
set_target_properties(wiretap PROPERTIES FOLDER "DLLs")
-# discover and substitute list of include directories for ABI compatibility
-# checks
-get_directory_property(INCLUDE_DIRS INCLUDE_DIRECTORIES)
-list(REMOVE_DUPLICATES INCLUDE_DIRS)
-string(REGEX REPLACE ";" "\n" INCLUDE_DIRS "${INCLUDE_DIRS}")
-configure_file(../abi-descriptor.template abi-descriptor.xml)
-
-# ABI compliance checker can be obtained from
-# http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
-# Checked using version 1.21.12
-file(GLOB HEADERS *.h)
-file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/abi-check-headers)
-
-file(COPY ${HEADERS} ../ws_symbol_export.h DESTINATION abi-check-headers)
+ABICHECK(libwiretap)
add_custom_command(OUTPUT libwiretap.abi.tar.gz
COMMAND cp ../config.h abi-check-headers/
@@ -144,7 +132,6 @@ add_custom_command(OUTPUT libwiretap.abi.tar.gz
COMMAND cp abi_dumps/libwiretap/libwiretap_* libwiretap.abi.tar.gz
COMMAND rm -rf abi-check-headers/* abi_dumps
DEPENDS ${HEADERS} wiretap)
-add_custom_target(dumpabi-libwiretap DEPENDS libwiretap.abi.tar.gz)
target_link_libraries(wiretap ${wiretap_LIBS})