summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-07-09 14:39:41 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2014-07-15 20:37:44 +0000
commit9ba0a18d1294b2b1b61fbdb5b6ed5b38a2cc3a97 (patch)
treedb61d7bb8f26f5e7f44eb5caf657a6c6f3ab1ff5 /wiretap/CMakeLists.txt
parent480089435746411ac973cc2d3146be6f7317ec5f (diff)
downloadwireshark-9ba0a18d1294b2b1b61fbdb5b6ed5b38a2cc3a97.tar.gz
Fix up library names when using CMake on Windows
Change-Id: I3573e69eb54044bb915161756dbb8f18cc769061 Reviewed-on: https://code.wireshark.org/review/2957 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt13
1 files changed, 9 insertions, 4 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 550ca4d86d..0bdb91fc28 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -117,10 +117,15 @@ add_library(wiretap ${LINK_MODE_LIB}
set(FULL_SO_VERSION "0.0.0")
-set_target_properties(wiretap PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")
-set_target_properties(wiretap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
-set_target_properties(wiretap PROPERTIES VERSION ${FULL_SO_VERSION} SOVERSION 0)
-set_target_properties(wiretap PROPERTIES FOLDER "DLLs")
+set_target_properties(wiretap PROPERTIES
+ COMPILE_DEFINITIONS "WS_BUILD_DLL"
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ VERSION ${FULL_SO_VERSION} SOVERSION 0
+ FOLDER "DLLs"
+)
+IF(MSVC)
+ set_target_properties(wiretap PROPERTIES OUTPUT_NAME "wiretap-${PROJECT_VERSION}")
+ENDIF()
ABICHECK(libwiretap)