summaryrefslogtreecommitdiff
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2013-10-13 09:21:55 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2013-10-13 09:21:55 +0000
commit9c4ee86784bd0f5cb02f7e7b7af639438352d83b (patch)
treebfaca5c6711a3f6ba372e99804a95240069f320d /wiretap/CMakeLists.txt
parentf5decf57f10d7d71410b431b4416ef719f05496a (diff)
downloadwireshark-9c4ee86784bd0f5cb02f7e7b7af639438352d83b.tar.gz
Add CMake properties to targets so that they are logically organised when using a Visual Studio solution.
Add CMake properties to group the source files in epan into logical blocks when using a Visual Studio solution. svn path=/trunk/; revision=52580
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index c4d0295eea..7fc2275da5 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -119,6 +119,7 @@ set(FULL_SO_VERSION "0.0.0")
set_target_properties(wiretap PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")
set_target_properties(wiretap PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
set_target_properties(wiretap PROPERTIES VERSION ${FULL_SO_VERSION} SOVERSION 0)
+set_target_properties(wiretap PROPERTIES FOLDER "DLLs")
# discover and substitute list of include directories for ABI compatibility
# checks